Applied colors & textures to "floor" are dark


#1

I know this must be a dumb newbie question - sorry in advance…
When I apply any color, texture or import a photo to the “floor” surface, it is much darker than the sample. As if the default dark gray of the surface is affecting it. Planes other the the “floor” behave normally.
Thanks in advance.

Scott


#2

Do you have a picture?
Is your “floor” below z=0 and have you turned on shadows?


#3

The only way I see that is with Xray on, and faces overlapping.

Check the “floor” to be sure you do not have 2 superimposed faces.

Beyond that we’d need to know what rendering styles are set, (Ie, on the Styles toolbar.)


#4

Thank you for the quick reply. Here is a basic example. I’ve applied the
same color to all the surfaces. I notice the inward facing surface of the
column on the left is also dark.

Scott


#5

It’S the normal style in SketchUp. You can influence the appearance with

  • shadows on/off
  • “use sun for shading” checkbox in the shadows window

#6

Light (and therefore, color) are not uniform in the real world.
The shading you see in SketchUp enhances the human perception of perspective.


#9

I’m trying to do a kind of trade show booth and looking to treat the floor, so having it make my selected image or color darker makes it less realistic in this case.


#10

The ‘light’ in SU is positioned behind the camera, so as you move around the shading changes according to your view.
Using sun for shading means the light comes from a specific point according to the time and timezone you have set and changes less as you move the camera around.
Setting the Dark and Light to the same level will make everything look pretty much the same.


#11

Thanks again.
I have shadows off.
In my shadows control window,the checkbox for “use sun for shading” is NOT checked.
I am doing a trade show booth, not exterior so would like to not use the “sun” feature, if that’s possible to turn off. Attempting to put an image on the floor, so having it artificially darker interrupts what I’m trying to convey.
Thanks for any suggestions.


#12

Box, thank you very much for taking the time to make that informative movie. Really appreciate that and seems to have solved my need.
The principle of using the sun for shading includes the time zone, but what about latitude? Angles vary a lot from equator to farhter away. Does that bring in the geolocation feature? Then, “sun for shading” accounts for latitude?
Thank you so very much again.


#13

Your stated goal is rendering an interior scene.
Geo-location and accurate shadows have nothing to do with what you’re trying to accomplish.

By design, SketchUp has rather limited light rendering capabilities.
If you want your images to be “realistic” then it’s time to look into photorealistic rendering.

Here’s a list of renderers; some are extension that work within SU; others are standalone applications.
SketchUp Sage Site > Resources > Renderers


#14

Yes, I understand geolocation doesn’t apply to this question. Sorry, I was expanding a bit beyond for my general understanding.

Thank you for the pointer to renderers.
And thank you for your kind help.


#15

Another possibility is that you have modeled the entire model ‘upside-down’.
These two views are with the exact same sun-shading/shadow settings.
This is with Z/blue solid axis downwards [wrong]


This is with Z/blue solid axis upwards [right]
Switch on the Axes to see…


#16

TIG, thank you very much for your suggestion.
I think my axes were on and I was in the positive direction, z-wise.
The suggestion to make dark/light equal in the ‘use sun for shadow’ setting seemed to get me where I was expecting.
Thanks again.