Misbehaving Colors and Shadows

I have a floor plan (ala Nick Sonder floor plans) that is showing some very strange behavior. I have assigned some colors/materials to some faces representing the floors. However, hen I view the plan WITH SHADOWS ON, it appears that some of the materials have disappeared but that room’s shadows show the proper color. When I turn SHADOWS OFF, the floor materials appear seemingly fine.

I have attached two screenshots showing the behavior.

Can you post the model here on the forum to troubleshoot? It looks like you have colors and materials mixed and the colors only exhibit the behavior you describe. Are all the materials stock or did you import them?

Yes I can upload the model. It might be a few minutes until I can.

Yes, it is happening to colors not materials. Everything is stock. Only hue was changed on one of the materials.

A dumb question: do you have Ground enabled in your style, and is the ground coplanar with the floors? And is SketchUp set to cast shadows on the ground?

  1. Ground was not enabled. However, enabling made no difference3 in the shadow behavior.
  2. Since the ground is not enabled, there is nothing coplanar with the floors.
  3. It appears so, since there are shadows being cast.

Building.skp (1.6 MB)

Exporting to PDF only gives you vectors. Try exporting to PNG.

Exporting what? Are you on a different thread, Colin?

When I opened your file and looked at the shadow settings I see that you have the Light and Dark sliders set way to the right. Your materials are disappearing because the settings you are using are washing them out.

Bring the sliders down to the left and the materials will show.

This is not a bug in SketchUp. It’s a user setting problem.

5 Likes

If you play with the shadow settings you will also discover that the shadows in the pale salmon area are actually those cast on the ground that are showing through because that material is translucent. If you turn off On Faces, they will remain but the others will disappear!

2 Likes

Good catch Steve. Opacity is set to 65.

DaveR!

You’ve saved the free world yet again. THANKS!

K

PS: and thanks to you too slbaumgartner !

Sorry about that, not sure why I thought you were showing an image and not a model.