Angles showing across multiple scenes

Hi,

I am trying to annotate the angles on objects within different scenes, and even though linear dimensions show only on the scene to which I add them, the angles show on every scene. It is the same with lines… and if I add a dimension to those lines it too goes everywhere.

I understand the layers, well sort of, but I am baffled as to why linear dimensions added to a scene seem to stay with the scene but angle dimension travel across scenes.

I hope this is as easy to answer as I hope it was to explain!
Thanks, Matt

I have added a couple of photos to show, there is one with some angled objects where it is clear all the dimensions and angles are where they should be, and another scene with a larger piece where the angles and other annotations from the previous scene also appear - except for the normal linear dimensions!

Adding dimensions in LayOut gives you more control then in SketchUp.
It also has a native ‘angular dimension’.
Probably, the angular dimensions were tagged with a layer/tag that is visible in every scene.

I’m the co-author with @slbaumgartner of Angular Dimension 2 which you appear to be using.

Angular Dimensions are given the default tag (formerly Layer) when they are drawn. This should normally be Untagged (or Layer0), and will normally therefore appear in all scenes.

If you want them only to appear in one scene, give them an appropriate tag and update the scene. But also use the extension Auto-invisible layer and turn it on so that the newly added tag is added only in the current scene.

That’s the way SU deals with any new tag.

You may have nested your linear dimensions inside the dimensioned component or group, so that its visibility will turn on or off with the the component or group’s visibility in each scene. Otherwise you have to visit each scene in turn, turn off the new tag, and then update the scene making sure that the Visible Tags setting is checked in the scene properties to update.

E.g.:
image

You could choose to do the same with Angular Dimensions, but it is probably better practice to keep dimensions outside the dimensioned components/groups and tag the dimensions separately.

1 Like

Perhaps I should have mentioned that I am only adding these dimensions and annotations in Layout.

It would be helpful to see your LayOut file. I have some ideas of what is happening but not enough information from your screen shots to identify it exactly.

Viewports can only be set to one ‘scene’, so you would need another viewport.
While ‘hooked’ to the SketchUp model, dimensions aren’t part of ‘Viewport’.

It is getting worse! the Layout software seems incapable of measuring the same thing twice and coming up with the same result.

Notice 70mm and 43mm for exactly the same measurement, 55mm for a cap larger than 50 mm (that it also measures at 31mm) where the 55mm as measured on an identical piece in the same scene is 88mm.

And yet, in sketch up itself (use the screen shot) everything seems fine and dandy, a couple of mm difference but I wouldn’t get bent out of shape about that! So if sketch up is measuring it accurately and layout can, when it is in the mood, how do I make sure layout stays in a good mood?!

If you can share the file, someone can give a better answer.

My guess is that in LayOut you are both dimensioning an edge you can see and dimensioning across a diagonal of a 3D object and that is why you get inconsistent values.

It seems to be drawn lines that are the problem… where I draw a line, if the measurement is to that it comes up short every time. In this screen shot I added a box in the rectangle to the left of the image and instead of measuring 45mm it measures 28 on the other parts 100mm becomes 61mm when measured to the extending lines. Why would this happen? It is maddening!!!

Here is the file: Flo-Ro Toys Final w Drawings.skp (1.3 MB)

I really do appreciate the time people take to consider this. Thank you.

How about sharing the .layout file since that’s where the bulk of your problem appears to be.

Looking at your SketchUp model file, though. It’s a really difficult model to work with because of the way you’ve used group and component nesting. You’ve also got weird stuff with loose geometry and components mixed together. The feet are a good example of this.

Oh my, I really am a dunce, I thought that was my layout file that I had shared! Here is the file, hopefully you can see how it relates to the sketch model and maybe see what it is that is going wrong / what I am not doing right.

Flo-Ro Toys.layout (1.3 MB)

You aren’t dimensioning the same thing twice, though. You are dimensioning different things. See below.


Looking at your LO file now. The viewport scale is set to around 1:1.64. Dimensions are set to Auto Scale. Dimensioning to points in the model will show the correct dimensions because the auto scale setting. If you dimension the lines you draw in LayOut, they will be paper space dimensions or 1:1 so it would be expected that they wouldn’t match the viewport. There are a couple of options available to you:

First, you could start a Scaled drawing and set it to match the scale of the viewport. The dimensions will then get scaled accordingly.

Second, you could set the scale of the viewport to 1:1 and then, whether or not you use a scaled drawing for the lines you add in LO, the dimensions will match the viewport.

I know which option I would go with. :wink:

As for the angle thing, the only thing I see that I find a problem is the angular dimensions on the part. Maybe that’s a preference though.