Already subscribed but the Sketchup Pro APP showing expired

I just purchased my annual subscription and my account showing the sketch up subscription is active.

But my SketchUp app showing my product is expired.
I have read SketchUp trouble shooting article and tried few time to log in and log out , even reinstall my sketch up. but the problem still hasn’t been solved yet.

I suspect Trimble hasn’t update my product status at their system yet, due to I viewed my product column in my account page and it is empty.

I have contacted them this morning and no one reply my email or request ( T_T)

As I am far from Malaysia , anyone can help me to report to Trimble to help me ?


SketchUp message pertains to your SketchUp Trial, not the subscription you purchased.

Try signing out > closing SketchUp > re-launch SketchUp > Sign in using the email associated with you Trimble ID.

I hope this helps


1 Like

Hi Chris D,

Sketchup technical team already help me solved the issue. Thank you :slight_smile: