All toolbar icons for non-native/extensions are TINY on my display


#1

When _ use my laptop at main office, second monitor, all is good. both monitors display correctly.
When I unplug and use the laptop independently, icons on all toobars that are not part of stock sketchup (all third party extensions) are super small. I have tried Workspace, Use large Icons. that’s not the issue. It’s very weird._ .

Actually, Joint PushPull and Placemeker and non-native…and those icons are fine.


#2

One of the third party extensions (Fredo Joint PushPull?) behaves scales as intended. Maybe the others use fix sized PNG icons while that one uses SVGs?


#3

Tools on Surface, for one, uses PNGs instead of SVGs for the icons. As @eneroth3, indicates, that’s part of the issue. Reduce the scaling on your display to less than 150% and that should help.


#4

Why would the laptop screen show sketchup and icons perfectly when hooked up to second monitor but go wonky when it’s standalone?

I’d like to have it so that I can work at my desk, via the port, and have second and third monitor (currently working fine) and then take the laptop on the road and have it function without monkeying around.


#5

Probably different scaling at the two screens.


#6

Guess I don’t understand that. the same laptop plugged in to two other monitors…unplug it…now standalone…and the toolbars are wonky.


#7

You might want to ask the authors of those extensions to redo them to use SVG instead of PNG images. The screen scaling thing is why SketchUp and some extension authors have switched to SVG.

If you restart your computer after disconnecting the second monitor, you may find that the graphics card plays nicely.


#8

The issue remains. When I have laptop hooked up to a port and two monitors at work, SU looks fine on the 3840 x 2160 laptop screen (and the two 1920 x 1200 monitors). When I disconnect from the port and the other two monitors and then start the laptop independently, the icons are wonky. Why would the SU icons behave like this? It’s the EXACT same computer processor, graphics card, and display screen on the same laptop.

If Trimble is monitoring this and wants to contact me I’d appreciate it.
I don’t have this issue with any other software.


#9

Extension icons only or native ones too? Old extensions use raster PNG icons while newer ones use vector SVG/PDF icons. Native tools also uses vector icons. Raster icons don’t scale up on high DPI monitors while vector icons do.


#10

Julia

The native tool icons are all good. All the extension icons exhibit this problem with the exception of PlaceMaker and Joint PushPull.

The strange thing for me is that when the laptop is standalone or docked at the other port, the icons are messed up at the laptops 3840 resolution.

But when I hook up to the port at my desktop station, sketchup looks fine …on the exact same machine/display!

Joseph Petrarca

DORE & WHITTIER ARCHITECTS, INC.


#11

What do you mean by hooking up a port? What is the difference between the configurations you describe?


#12

I have a laptop dock/port at my workstation and also at my second location.

At the workstation I have two monitors in addition to the laptop.

At the remote station I have an identical dock/port and one monitor.

Joseph Petrarca

DORE & WHITTIER ARCHITECTS, INC.


#13

theoretically, SU solved the issue by introducing the vector icons, but they have little control over, if or when, extensions get updated…

converting such small icons to vectors using code doesn’t work [I tried] so the only option would be a pixelated up scale…

this is better handled on a per user basis, rather than en-mass to the unaffected…

I wrote a ‘prototype’ ruby that works on my mac, but I don’t have either a windows PC or a high res monitor…

at the moment it involves running from Ruby Console and selecting a folder full of ‘undersized’ icons…

you would need to make a back icon folder first, just to be safe…

if you want to try it I can PM you a copy…

john


#14

Thanks very much John.

We finally figured out that although my laptop is 3840 resolution, the monitors are max 1920 resolution. So we took the resolution of the laptop display down to 1920 x 1200 and that seems to have solved it.

It was strange that when we had the laptop, at 3480 hooked up to two 1920 res monitors, the laptop did fine. Sketchup displayed fine. But when we went to another workstation with different monitors, even one, it did not play well. The display of sketchup icons on the laptop were tiny. And then when the laptop was completely standalone, same thing…sketchup couldn’t deal with the 3480 res.

For some reason with my two 1920 monitors it could. Very odd. Now everything is at 1920 and seems to be OK.

Joseph Petrarca

DORE & WHITTIER ARCHITECTS, INC.