After upgrading to 2021 - Error: #<Errno::EACCES: Permission denied @ rb_sysopen

After upgrading to Sketchup 2021 I have been receiving this error on startup;

Error: #<Errno::EACCES: Permission denied @ rb_sysopen - C:/Users/Rick/AppData/Local/Temp/SCF/SketchUcation_Usage.log>
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/!scfapitools.rbe:192:in initialize' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/!scfapitools.rbe:192:in open’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/!scfapitools.rbe:192:in log_write' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf-rbztools.rbe:181:in rescue in module:RBZtool
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf-rbztools.rbe:175:in <module:RBZtool>' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf-rbztools.rbe:158:in
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:66:in eval' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:66:in require’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:66:in block in load_files' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:64:in each’
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:64:in load_files' c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:69:in module:SCF
c:/users/rick/appdata/roaming/sketchup/sketchup 2021/sketchup/plugins/sketchucation/scf_loader.rbe:13:in <main>' C:/Program Files/SketchUp/SketchUp 2021/Tools/extensions.rb:197:in eval’
C:/Program Files/SketchUp/SketchUp 2021/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2021/Tools/extensions.rb:197:in load’
C:/Users/Rick/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins/SketchUcation.rb:181:in register_extension' C:/Users/Rick/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins/SketchUcation.rb:181:in module:SCF
C:/Users/Rick/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins/SketchUcation.rb:17:in `<top (required)>’

I do not get ther error if I disable Sketchucation tools
I have repaired, removed and reinstalled, removed previous versions (now I’m worried) and tried everything I know. I believe I am missing a script?
There are multiple “fixes” but all of them are 2 -3 years old and incompatible wioth my Windows 10 system.
Any ideas?

Did you install the current version of the SCF tools or did you copy from an older installation?

When you installed SU2021 did you do it correctly? That is, did you right click on the installer and choose Run as administrator from the context menu?

Originally I copied from an older installation. Realized I could not do that. Deleted the older installation, uninstalled SU2021, reinstalled SU2021 with “run as administrator”.
The problem is that this is ongoing. originally I did just as you suspected. Double clicked the install and hit run, installed from the existing plugin files…
I was told to delete a gem file which I did… I believe a bad move. I held on to the info for quite a while, now I do not have the info and do not know the file I deleted.

Try this. Close SketchUp. Go to User/AppData/Roaming/SketchUp/SketchUp 2021/SketchUp/Plugins. Find the folder called Sketchucation and the .rb file with the same name. Delete them. Then go to User/AppData/Local and delete the SCF and SCF Licenses folders. Next, go to Sketchucation and get the latest version of the tool here. Download it and then use Install Extension under Window>Extension Manager to install it. Quit SketchUp again and restart it.

If you still have issues, post on the Sketchucation forum so those who maintain the tools will see it.

Thank you for your help. I have tried it and still get the errors. I will post the question on the sketchucation forum. Thanks again!

I’ve answered this over at
Using the wrong installation method can skew folder/file permissions irreparably…

The SketchUcation toolset writes a log file used in our own debugging.
It does it silently as you use its tools.

Fortunately the error is quite clearly explained in the error message [often it can be somewhat arcane !]

SketchUp is unable to open the log file to write into it - this suggests a folder/file permissions limitation which was probably created by initially installing SketchUp incorrectly [i.e. not using …right-click installer’s exe > “Run as administrator”]… subsequent corrections of the installation - perhaps using ‘Repair’ - didn’t reset that particular permission as it’s outside the main ‘SketchUp’ domain…
A simple fix would be to exit SketchUp and use Windows Explorer to open the Temp folder
Then delete its SCF subfolder.
This will delete the subfolder and its contents [i.e. SketchUcation_Usage.log], if any.
When you restart SketchUp and the SketchUcation toolset loads it will not find the subfolder or log file and recreate both of them, this time using the correct permissions as were reset by any ‘Repair’ you might have done to the main SketchUp installation…

1 Like

Thank you TIG.