SketchUp "Permission denied" error

I am getting such an error on trying to create the PV Layout using SunDAT extension. Can you please suggest how to resolve this issue?

Did you install SketchUp by right-clicking the installer exe and choosing “Run as Administrator”? Installing any other way can lead to strange errors due to permission issues. Try getting the installer again, running it that way, and choosing “repair”.

Failing that, take a look at the file path listed in that error and make sure you have write permission for each folder level within it (some might not exist yet due to the permission failure).

Thanks for the suggestion. It did help when I did as you suggested and was able to get results. However, it has again started to show the same error.

Can you please suggest a permanent solution?

I don’t know how the Sun DAT extension works, so if repairing the install only worked temporarily I don’t know why. I’d suggest you contact them directly for help,

Okay, I will contact them. Thanks for the assistance.