Adding Symbols to Sketchup Text often results in a box

Yesturday I was adding some text to a model and needed a heart… I had never looked at clipart/symbols before, but when working in other Apps, I simply look up a symbol online and copy/paste it.

So I did this and found a nice heart “:heart:”, but although it appeared as a heart in the text box, when it appeared in 3D it was just a box.

I tried again with another symbol “:heart:” and it was the same…

I was about to give up and I found this one which works “:heart:

You can see the results here:

Any idea why 3 of these symbols are not supported? Are there any other ways to add Symbols? I did play around with the Windings fonts and found a few options… But that was quite fiddly as you have to use the Windows “Character Map” to find the symbol you want… And then copy/paste it in against the correct font…

Just to be sure it wasn’t a fluke, I tried the same with a diamond (:diamonds:♢⟐⟣⬥⯁⧱⬩) and again only 1 is supported.

Does anyone have any idea whay its doing this?

Jon

If you know or look up the code and use webdings you’ll get what you need.
A capital Y for example will give you a heart.

That was almost how I worked around it yesterday… I didn’t know abouit CTL+Y, so just copy/pasted like this and used the Webdings font::

Buts not the easiest of solution as its difficult to find the character/symbol you need… It would be nice to be able to copy/paste symbols from elsewhere like you can with most if not all text based apps.

Its odd that the Text dialogue window supports and shows the symbols (in the case hearts), but they don’t end up in the 3D view…

Edit: Actually I lied… I used THIS one instead from the “symbol” font:

image

You might have better luck with Thomthom’s text tool.

mihai.s

You have totally missed the poiint… Thats exactly what I do…

image

My point is this:

When copy/pasting symbols from other sources, the SU Text window shows them… But when you place the, only 20% of them actually work…

Nope… Exactly the same

image