Ability to group like layers

We do most of our upfront work in Revit. Then we export the file out to .DWG. once in sketchup we import the .DWG file. after that we have to click on the group (has all the layers in it ) then create groups within the group. after all the layers are grouped we explode the combined group. then in each group layer we click on the group and send all elements to Layer0.

what we have left is all groups keep the parent layer, but when we click in the group everything is on Layer0. this keeps us from having a nested layer issue

Is there an easier way to do this?

You could try this:

1 Like

I did that before but it doesn’t group like layers. also need to clean up triangle faces.

There is a lot of confusion about the concept of Layers in SketchUp, they are basically just ‘Visibility Tags’
They do not isolate drawn geometry, as you experienced.
The triangulation might be solved with an extension like cleanup3 from Thomthom, for the other part of the problem, it also depends on how the CAD file is organised, originally.

1 Like

I do it differently…

Layer Mode: ‘ColorByLayer’
Edge Style Color: ‘Same As Material’

Explode the wrapper >> ‘Select all with same material’ >> selection to ‘Layer0’ >> ‘Make Group’ >> add group to original Layer…

john

2 Likes

More workarounds.

When I am importing a less involved file I group (block etc.) the items in each original layer-- I put it all on a CAD Layer0, prior to import,