A serious amount of gaps everywhere!

I have been working on this model and its a mixture of a premade magazine and some modifications. During the changes made, a serious amount of gaps were made everywhere! Is there a way to more quickly remedy these? I am fairly new to Sketchup and learning as I am going. I appreciate any help!


Hell I would pay to have someone fix this for me that is WAY better at it then me…

You are working too small (sorry, but life size for this is too small - Sketchup can’t handle small edges well), and your model has, or you have tried to create, edges that are so small that they get collapsed or deleted.

Try starting again with your import, make it into a component if it isn’t already, scale up a COPY of the component by a factor of 1000 (so use metres as your unit, instead of mm), edit the large copy, which will reflect the changes correctly back into the original.

Examine the original after your edits, and when you are happy with it, delete the large copy.

Search this forum for ‘the Dave Method’ for more details.

Thanks for that. Learning as I am going here. The majority of the things I work with are small so this will help me a lot!

There’s no point in attempting to fix the model you shared on Dropbox.
The root of problem there is the geometry is far too small (read microscopic) for SketchUp to work with.

We’ll have to presume the readymade file you started with was an STL file.

Look under the Options button when you import the STL into SketchUp
Use the Import Options settings shown below.

Scale the model down to real world size when you’re finished with the modifications.

STL Import Options

It’s a result of the history of SU. It was originally developed with Architecture as the target market, and can handle a wide range of scales from mm up to many km (originally, small fractions of an inch up to many miles).

But it has a ‘baked in’ tolerance of about 1/1000th inch (it’s own ‘natural’ units are inches), and will consider points closer than that to be the same point.

So if you use native tools like FollowMe or (less commonly) Offset, they can create very small edges which SU thinks are not distinct from each other. It won’t create such small edges, but will preserve them if they are created in a larger size and then scaled down.

Ok, so moral of the story is, design at say metre scale and then reduce back to required when all done. Seems from everyones feedback that this is definitely the problem. Thank you everyone for you input…back to the drawing board!

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.