4K Compatibility: Tray windows scale only after moving

bug

#1

So, i have a Win10 4K Laptop (with recommended 250% scaling), and a ~2500px something width external display (125% as recommended).
When i drag a tray window, only a preview-window-border is shown until i release.
That’s normal so far.
If i drag it over to the laptop screen, the size is wrong, too small, it’s not using the DPI scaling. Because of that, also the position is incorrect, aka, the border does not move at the same speed as the mouse.
If i release, the window is scaled to the desired, bigger size. But the position is also different, because of the scaling.
So it’s quite cumbersome to get a nice setup for my tray windows…
But now, after i close / reopen, the tray windows are small, not scaled, until i move them! So i have to resize every time again…
Super annoying.

Here’s a Screenshot of Tray-windows, one moved=correctly scaled, one as-is after re-opening SU=blurry, no scaling applied:

SU is on Screen 2 (set as main screen, 125%), trays on Screens 3 (100%) and 1 (250%)


#2

Hello, this appears to be caused by a couple of things you have set up.

  1. Multiple Monitors: The monitor SketchUp is set launch from will determine the scale of dialogs. Also, we officially do not support multiple monitors, but with this said, SketchUp’s dpi is based on the 1st and all additional monitors will display based on the initial monitor.

  2. 250% Zoom: Currently we cannot support over 150% scaling. To get around this I set my screen resolution to a lower number and my zoom scaling to 150%…

I hope this helps.

Trent


#3

Thanks.
I’m Surprised and confused about

Confusion:
It is officially stated somewhere (where?) you do NOT support, or you do not “officially support”?
Or are you only talking about different DPI monitors?
Surprise:
So many of your ambassadors like Donley etc. say multi-monitors ara a must, and also, the use of palette windows vs. docked palettes make more or less only sense on multiple monitors i think…

How does that fit with the 2017 announcement

High DPI Modeling
We’ve tuned snapping and inferencing for high definition monitors (like Apple’s Retina Display). Edge weights have also been smart-scaled. You can back away from your screen now…
Is that Modeling marketing speak for ONLY Modening, but not UI? No general HiDPI compatibility, just the modeling area?
Well, like that, i can’t back away from my screen as i’d like to.

Back to the issue, i have to admit i mixed SU and LO in the post above, and now i am not sure if you did too.
Is Trimble officially supporting the same system specs for both, or does it differ?

They behave different, neither bug-free. Aparently, they have a very different code-base with a different UI framework? LO seems to work less nicely with windows than SU. LO only shows frames of moving windows, which are still heavily flickering, while SU cleanly shows moving windows with content.

SU:
The Scaling is taken from the Screen on which SU starts.
On the 4k 250% screen there’s no scaling as you said.
On the 100% 125% screens it scales correctly, but only after a window is moved, so my saved setup is never correct upon re-opening SU (tray windows all set to the same width on the same screen):

LO:
It’s always taking the DPI from the system-primary screen, regardless on which it started. (Splash is always on primary)
Also, it reads the DPI in a way, so only after a reboot it gets the new value, changing display settings is not enough.
Moving trays on a screen with different DPI, the tray-window moves at different speed than the mouse.

This makes LO only work correctly on the system-primary screen… Is that covered with the official non-support for systems with multiple monitors, or is it a bug :wink:

As for the Answer 2), this is a workaround for the 4k display, half the resolution still looks good. But on the 100% 125% screens, which are the big ones i use, it’s not really an option.


#4

Here is the link on our help center describing the dual monitor issue http://help.sketchup.com/en/article/3000139

and the HiDPI Support article http://help.sketchup.com/en/article/36208

I agree, there is no question that working with the modeling window on one monitor and dialogs on the other allows for more modeling real estate. We cannot guarantee that all facets will function as originally designed in these mixed states.

Your original question was directed toward SketchUp, but the same system specs apply to both SketchUp and LayOut so I felt comfortable engaging in this post.

And for the workaround I had mentioned, the intent was to leave the resolution you had set for the 100% and 150% monitors alone and just change the resolution lower on the 4k and set the zoom to 150%.

Thanks
Trent


#5

Hi Sirtet
Did you find a solution to your dual screen set up (back in January) that gives you satisfactory result with Layout? I have just upgraded to a new laptop and I am using the same old secondary monitor (now connect via hdmi rather than vga) which worked perfectly fine with my old lappie. Now I have the same issue that you have described with Layout menus lagging behind the mouse and never really end up where intended, sometimes even jumping back onto the primary display… the enlarged scale is also annoying. Any tips you can share?

Thanks David