3dwarehouse log in issue - Trimble Log in details not visible

Trimble Log in details not visible. Am trying to Log in on my 3dwarehouse account, I get redirected to Trimble but the form for logging in is not visible, the left part of page under the Trimble logo is completely empty except for the help/privacy/terms section at the bottom. See image below.
Have tried multiple browsers; Brave, Firefox and Safari, with same result. Have also tried with/without Little Snitch and VPN, same result.
Have never had any issues logging in previously, but have not logged in for about 7 months and don’t remember being redirected to Trimble to be able to log in.

Please help, not sure what to do.
Cheers Jen

The URL is now id.trimble.com, previously it was identity.trimble.com. Your system may be set up to allow the old URL, but not the new one.

Is it possible you need to whitelist id.trimble.com?

It looks like someone was testing the id.trimble.com link. It doesn’t work on its own, but will when there is parameter data in the URL.

Hi Colin, thank You for your reply. Have a newly installed mac, since about a month ago, so not the same as I previously used with 3dwarehouse. The URL I get redirected to is: id.trimble.com/ui/sign_in.html?state= (with the token/parameter data inserted here), checked site settings and nothing should be blocking it.
Checked everything else I could think of, such as adblocker, cookie blocker etc. and nothing there.

Seems very strange to me, cause it’s a new installed mac with no clusters from anything old that should disturb.

If you go to 3dwarehouse.sketchup.com in a private window, and click on sign in, is the form still missing?

If it is missing, do you see any errors in the JavaScript Console? You may need to go into Safari preferences, Advanced, to enable the Develop menu.

Hi Colin, thank You so much for your assistance and aid.
I just did a more in-depth look at Little Snitch and it looks like it was the cause of the issue.
I initially tried all 3 browser with little snitch up and running, it did ask for a few permissions but seemed to leave the accounts.sketchup.com greyed out without asking. So when I changed to allow all connections on my 2nd try, it did not allow for the already greyed out connections.
I stopped Little Snitch network filter and it allowed for the log in fields to be displayed and I could also log in successfully.
So as for now I have Little Snitch running as usual but have manually allowed accounts.sketchup.com and I am logged in and able to download.

Thank you so much for your assistance.
Not sure if I should leave this thread to assist someone else or delete it.

Cheers Jen

Thanks for the detailed report, and please leave the topic here. Someone else may have the same issue, and not think about checking Little Snitch.

Thank You for your patience and time. Will leave the thread up just in case.
Wish You a wonderful day :grinning:
Jen