3Dconnexion Space Mouse for SU Pro 2021 on macOS 10.15

The current macOS version of 3DxWare seems not support SU 2021, but I’ve been seeing the host of the SketchUp channel on YouTube using the space mouse in SU 2021 on his Mac for a while. Does anyone know how did he manage to do that?

Their beta for Big Sur also happens to work with SketchUp 2021:

I have had one glitch where connection to the SM dropped. Restarting the computer fixed it though and I haven’t had it since.

It is a little disappointing that the driver is still in beta so long after release of Big Sur.

I couldn’t get SM to work with 2021 Pro on either my iMac running Catalina or my macBook Pro running Big Sur. 3DxConnexion tech help pointed me at the latest betas but that didn’t help. The plugin showed up in Extension Manager but without any version number, author, or description information.

Out of curiosity I fired up the Ruby console in Sketchup and ran 3DxSketchup.rb from its installed folder and suddenly the SM was working.

I’ve since moved the plugin from /Library/Application Support/Sketchup 2021/Sketchup/Plugins to ~/Library/Application Support/Sketchup 2021/Sketchup/Plugins and all is sweetness and light.

I spoke too soon!

Moving the plugin to the ~/Library/Application Support/Sketchup 2021/Sketchup/Plugins folder leaves my macBook still working happily with the SM but a restart on my iMac has me back to square one.

I repeated something that I found had worked a few days ago namely

  • open the Ruby console in Sketchup
  • type 'load ‘3DxSketchup.rb’

After a short wait it returns ‘true’ and the SM works again.

Anyone any suggestions as to what is going on?

I see that they updated the Mac version a week ago. Could be worth trying the new one.

Many thanks for that Colin. I’ve just installed the latest driver but no dice.

After installation and a reboot I go to Extension Manager and look at the details for the 3DxConnexion extension and it’s there but the data is blank.

If I run load '3DxSketchup.rb’ from the Ruby console I get

and the mouse works.

I reported this to 3DxConnexion support on 21st January and had this reply on 2nd February:

Screenshot 2021-02-16 at 11.31.44

It would be nice to know if it’s just an anomaly with my iMac and/or setup or whether others are still struggling.