3Dconnexion settings for Orbit


When I orbit using 3Dconnexion the action is very slow, comes to a halt sometimes depending on the complexity of the drawing am working on. Mostly Landscaping with lots of trees and shrubs and detailed models.

However, when I orbit using the mouse I noticed that the complex models turn into rectangles and the orbiting becomes responsive.

So it seems that mouse orbiting renders rectangles to speed up orbiting, while 3Dconnexion does live orbiting which makes the action slow and unresponsive at times.

Is there a way that I could make orbiting using 3Dconnexion same as that of mouse, i.e. models turn into basic rectangles?

Hi Ismail,
you can change the rotation speed at the 3DConnexion Driver. Also you can change the rotation mode (Target, Camera, Object and so on) at the Driver Settings.
Kind regards, Bernhard

Thanks for the comment. I’ve already been through the Driver settings and what I am looking for is not there.

It seems that the mode of display is changed when using mouse orbit as opposed to 3Dconnexion orbiting as shown here:
So is it possible to make 3Dconnexion change the mode while performing its job?

Hi again !
What kind of Hardware you are using (Graphiccard)? Driver up-to-date?
What kind of presettings (SketchUp / Windows / Presetting/ Open GL) you have done?
I’m using a GeForce GTX1070 without this behavior.
Have a look at the Screencast. Moved with 3DConnexion Space-Pilot.

Kind regards,

Graphics: Quadro M4000
Settings: 4x anti-aliasing, Using fast feedback, NOT using maximum texture size

Hello Ismail,
Same settings as me.

We use SketchUp since release 6
So far our experience shows that SketchUp copes better with gamer graphic cards.
That’s why we have NVidia GTX cards in all our workstations.
Our other CAD programs (Revit, Inventor, AutoCad, etc.) have no problems with the GTX cards.
The M4000 is a CAD graphic card. It is not designed for speed but for precision.
Only my two cents
Kind regards, Bernhard

Several versions ago, SU instituted the wireframe while orbiting as one of the things to improve performance. Have you asked 3Dconnexion support on what its navigator taps into to fly around the model?

Try disabling fast feedback via SU in Window > Preferences > OpenGL? Fast feedback is something that kicks in when the model get large to improve performance - which should benefit - but could be worth checking.

As you are using a laptop, are you using the NVidia card for SU? Try r-clicking on SU desktop icon. One of the Win10 context menu options is to choose your graphics performance.

Thanks for your comments.

I tried your suggestions, it didn’t help much to my hopes.

Since the model I am working on has lots of trees and bushes with textures it seems the live-view orbiting as done by 3Dconnexion is slow by nature. While when I orbit using the middle button or Orbit tool, textures turn into plain colors while trees and brushes turn into rectangles which speeds the orbiting action.

So, I figured that I would just go into Orbit mode when ever I want to change the view using 3Dconnexion, that apparently kicks in the action of changing textures into plain colors and the orbiting becomes very responsive.

I believe you’re right about contacting 3Dconnexion to follow-up on this.


And you may want to use 2.5d trees instead of a lot of poly heavy ones to improve orbiting too. The face me component method used with 2.5d landscaping.


The 2.5d suggestion is a great suggestion that I am not familiar with at all! Thanks.

I use face me component method for species that I can’t find 3D models for. But it looks Ugly when I orbit in front of customers to explain the drawings.

I have just done few searches for a 3D to 2.5D converter, without luck. Could you please suggest a way to carry out the conversions with the 3D models I already have so they will be 2.5D proper just the like the link with 2.D tree you have posted?

There are more 2.5d landscaping models in the Warehouse. And that second link takes you to some tutorials on how to make them.

Deconstruct the 2.5d models from the warehouse to examine how it was done - there’s no converter.

And with the 2.5d trees you add to SU, if you make a copy > r-click > Make Unique, you can remove the trunks and the component becomes a bush/ground cover.

1 Like

Hi All. I’ve Been experiencing the same issue with the Space Mouse Pro Wireless on some larger models> So I just wanted to say thanks. ismail’s comment about going into Orbit Mode worked for me.

Still not crazy about SketchUp performance when shadows are on. I have it set at 8x Anti-aliasing.( Will try changing to 4.) shows the option for 16x. Fast Feed Back is checked , Maximum texture is not checked.

Running an MSI GE73VR laptop with an Intel i7-7700@2.80 GHz, Nvidia GTX 1070 , 32GB Ram. All drivers are up to date.

I’m curious if fetzerman experiences any issues with the GTX 1070 and shadows on your Desktops?

The dwg I’m working on right now is 133 MB (140,418,713 bytes) really not large compared with dwgs I used to work on in the construction industry. AutoCAD, Practicad, Revit,

Be Well. Happy New Year.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.