3D Warehouse download very very slow

Hi, anyone else experiencing long time downloading from 3D Warehouse, it takes like 5 to 10min…anything that can be done to speed it up? thanks for any tips in advance

Turn of iCloud ‘syncing service’ in the system preferences:
System Preferences->Apple ID->iCloud Advanced: turn of Desktop and Documents

Report if it makes any difference or not.

this solution will affect storage of my other documents, I won’t really go with it…anything that has been saved will be stuck on iCloud driver only and in the future none will get saved on iCloud, both this options are needed for me…anything else please?

It is a bug, the workaround is to look for products and download in a browser, say a (special) folder and add that folder in the component panel to your collection (little blue details button, ‘Open or create a collection’)
You didn’t say if the first solution worked, was curious about it.
You might want to check if you have the latest version installed (‘check for updates’)

I can’t even try the first solution by deactivating in the cloud the sync all my current documents will get stored only in iCloud drive, don’t want to have this change…yes I have the last update just downloaded today 2020 Sketchup…I didn’t get your suggestion very well…but only by trying to read the steps I kind of think it’ll take me same long time to get through the whole process…really there must be a better solution to fix the downloading time…it is very time consuming…

Open a browser and go to the 3Dwarehouse.sketchup.com search and browse, create collection and order your folders, there.
Then download in a folder you created, instead of the normal download location. This way, you can even inspect and ‘tidy up’ the files prior upon inserting them in the main working model.
This can be done more easily if you create a collection in the Component Panel, and choose that folder.

ok, will try in the next download to see how it works…will let you know but thanks so far…

so I have my folders already created,I’ve opened in browser the collection and downloaded the component afterward importing in the model from downloaded items, worked faster - what I don’t know if all this downloads I will have to delete from laptop not to overloaded with skp files…

would it be though possible to get the bug fix announced, it is definitely taking quite some manual steps to get a download, not really convenient…thanks!

Continuing the discussion from 3D Warehouse download very very slow:

I’ve been having the same problem with the components. It takes forever to download anything no matter the size. And don’t think that deactivating the cloud sink is an option because that’s the way I see my documents. Like Melindah said, can’t this be reported if it’s a bug?

1 Like

If any help, short term, I went with suggested option to rather use via web the warehouse, download the object on pc/laptop and afterwards import it in SketchUp, it did worked way faster, at least the download and import…best of luck in getting it solved!