3d warehouse doesn't see my network connection


#1

Using the 3d warehouse, it (almost) always stalls on searches and says it can’t find a network connection, though I confirm mine is open and working. This has been an issue since I upgraded from Make 2014 to 2015. I’ve cleared cache, cookies, etc., and reinstalled Make. Appreciate any help!


#2

If you can’t find a network connection, the way SketchUp checks to see if there’s a network connection is to go to the web site http://www.google.com/ncr (NCR stands for no country redirect). In 2015, it should be the same unless you’re not using the English version. In 2015, we put that variable in the file (Mac) /Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Resources/en-US/i18n.dat (replace en-US with your language). If you cannot hit that website, you can change it to whatever is quick and fast for you, i.e. change line 13 from

ONLINE_TEST_URL=http://www.google.com/ncr

to a fast website for you:

ONLINE_TEST_URL=http://www.trimble.com/

or something similar.


#3

@mbewley59 Please fill out the 3 computer questions in your profile. If you run Windows you might check in Device Manager if your network adapter has any conflicts. (Some ppl reported that their BlueTooth adapter was conflicting with their network adaptor, and disabling BlueTooth solved their issue.)


#4

I checked the file and it points to …google.com/ncr. I can access that website fine with my browser. I tried to change the entry to straight google.com, but it won’t allow me to save, as if my admin status is no good there. Also, when I first bring up the components window, it does load all those random sample models below the search field, so I assume it is getting at the internet at that point, though after I’ve entered a search and submitted it, it hangs and finally, after a couple minutes, says it cannot connect to the internet, etc… Thanks for your help…


#5

Also, I did verify that the network adapter has no conflicts, though there are two listed…


#6

Disregard the last - that was the ethernet port controller


#7

Can you get Extension Warehouse to come up?


#8

Strange- I went out yesterday and opened the google.com/ncr site a couple times with my browser, and now my components warehouse comes up and functions fine… no idea what’s going on, but I’m up and running. Thanks guys!