3D Text Editor "NOT WORKING"


My 3D text editor extension just work fine until today it stop working.
Is there anyone have to same problem ? or anyway to try to fix this problem ?

Below is my system info. I already update SKP latest version and reinstall extension, problem is still not fixed.

Thank you for your help.

SKP Editable 3D Text Not work3

This will probably help.

1 Like

Hi Box,

Mine is like this, see attached photo.

It is just a blank window pop out of the 3d text editor

Thank You

Hmm… Strange

I try to fix by copy old 3D editable text and place to reuse. Then window popup will come back.
However if I open new file, window pop up will not show again.

I am going to check Box’s link. Thank you for your support.

Yes, there appears to be an issue with a recent update I think.
The text dialog always opens at one point, and if that is offscreen you have to keep moving it.
I’ll @thomthom to get his attention.

I already try Alt+Space bar, it still not work.
Maybe problem with recent update.

Hm… maybe it was related to recent TT_Lib bug. Can you all update TT_Lib and try again?

1 Like

I tested with latest 3D Text Editor and TT_Lib under Windows and Mac (SU2022) and the dialog appear correctly in both cases.

I have the most up to date of both from the E warehouse and it always opens in the same place, which is the wrong screen for me, but easily grabbed and moved. But it won’t retain the memory of where it was moved to.

Thank you TT from your attention.
Seems my problem is fixed. Not sure if it is because of update but now Editable text is work again !

Thank you for your check.

Editble Text work

Editble Text work2

1 Like

Hi Box,
Not sure if this info will help. Below is version I am using and it just back to work again.

I have the same.

I have the same versions as well, but then I never had the problems reported !

Did you have 2.13.0 installed? That was the version with the regression. Earlier versions worked fine.

Hmmm. I just checked and I have 2.13.0. Extension manager gives no notice of an upgrade.

Hi Box,

Finally it worked!!! I uninstalled the TT_lib2 and installed the latest version 2.13.1. Just like @johnston52 I never received a prompt for it to update so I did manually.

Thank you guys for all the help.

1 Like

That’s strange. Where did you originally install it from?

I have been following this thread, I also have not seen an update is available for Lib2. The original was installed from the extent warehouse. Additionally I have not experienced any issues.