3D DWG Export shows up as 2D in Edrawings

I recently purchased subscription to Sketchup Pro 2023 with the hopes of exporting 3D model to DWG for interchange with vendors. However, whenever I export to DWG and try to view the file in eDrawings, the 3D is always a flattened 2D image. However, if I import this DWG file back into Sketchup again, it appears like the original.

This happens even if I just draw a cube like enclosed “test.skp”.

The resulting image in edrawings looks like “test in edrawings.png”

Am I missing a setting in either my export or viewer?
Note: I have viewed other 3D files in eDrawings that seem to work correctly. Thank you to the community for help.

test in edrawings|690x371

test.skp (70.6 KB)

I just exported the file you sent to dwg 3D and its exported perfectly fine, also the image you shared shows the cube in 3D.

Thank you, Francis.

When I export the DWG, the enclosed file is what I get. Unfortunately, when I open this DWG in eDrawings, it does seem to look like a 3D model but actually it’s only 2D and I cannot pan or rotate the model. Only the view that I was last on in Sketchup is what appears.

So right now, I’m trying to figure out if it’s the DWG exporter or a display issue in eDrawings.

test.dwg (83.8 KB)

It should be

I never used eDrawings, but the test.dwg you posted is a perfectly fine - rotatable, panable - 3D cuboid in Autodesk TrueView.

In edrawings, use the arrow tool to select the cube, then switch to the orbit tool. It’s not a terribly great program, consider switching to DWGsee or CST CAD Navigator or as you are on windows the free Trueview.


Thanks, dezmo and endlessfix.

I installed DWG TrueView and found the .DWG is a perfectly rotatable cube as you say. However, it does give me a warning “This DWG file was saved by a software application that was not developed or licensed by Autodesk”. Perhaps this is why eDrawings doesn’t like it (?) I also uploaded the DWG file to AutodeskViewer online and it is also a perfectly rotatable cube.

In the end, I’m not sure why in my eDrawings the DWG appears as 2D . I couldn’t even select the cube to get a rotate/pan option. That said, once I start clicking around, I found if I click on “Sheets” at the bottom right, then expand “Model” and click “Drawing View 1” and the “Layouts” icon – then suddenly the cube is “freed” from its background and becomes 3D.