3D Connexion Space Pilot Sketchup Make 2017



Haven’t used Sketchup since 2014 and haven’t used my Space Pilot since then either. Now installing SketchUp 2017 on my laptop gains me no use of my Space Pilot. Not only that, I can’t locate the 3dxsketchup extension anywhere. SpacePilot works when I first install the latest 3Dxconnexion driver, but once I start Sketchup it’s NO GO.


Lenovo T410 2522
8Gb memory
250Gb SSD drive
Windows 10 Pro (latest update)

3D Connexion driver is 3DxWare 10 for Windows (64-bit) 10.5.5.


Did you try going to the 3D Connexion site and downloading the latest drivers? You’ll need the newer ones to run on the newer version anyway.

Don’t use the old driver. And while you’re setting up SU2017, make sure you install fresh copies of any plugins and extensions you might use. Do not copy the ones from your SU2014 installation to use in SU2017 unless you enjoy chasing load errors.


10.5.5 is the latest 3D Connexion driver. I also went backwards to a Windows 7 driver. That didn’t work either. I’m concerned that I cannot locate the 3DxSketchup extension Anywhere.


Since version 2017, there is no Hardware acceleration support, the OpenGL-requirements have gone up.
The OpenGL support of integrated Intel graphic cards is proven not to be sufficient, so that might cause some issues.


So perhaps I need to go back to me Dell T5500 workstation and run sketchup from there. It’s got an NVidia graphics card with 6GB memory and is rated for/was used with Catia.

This is the sound of me scraping the rust off of my technical knowledge. I’m retired now and am a woodworker hobbyist.
Thanks for the info, I’ll check it tonight.


Did you install the latest 3Dxconnexion driver before or after you installed Sketchup 2017?

If before, you’ll need to re-install the 3Dxconnexion driver. Part of the driver installation includes looking for compatible programs and installing any necessary supporting software (like the 3dxsketchup extension) in the proper location.

So the extension is only installed if Sketchup 2017 was present when you installed the driver. And since new versions of Sketchup installs without disturbing previous versions, the 3dxsketchup extension for an older version won’t carry over to the newer version.

Note: This is my understanding of how the 3dxsketchup extension comes to be correctly installed at the proper place in the filesystem. Unlike other extensions, it isn’t available through normal channels (extension warehouse, Sketchucation, smustard, etc.).


No, but…
Sketchup 2017
Install Space Pilot
Download & install latest driver.
Uninstall Sketchup 2017
ad infinitum, ad nauseum. :face_vomiting:
I didn’t have either on this laptop prior. And I’m starting to think MikeWayzovski above may have the correct solution. I’ll verify tonight when I get home. I hadn’t wanted to spend the money to upgrade hardware but the time may be fast approaching that I need to kiss my T410s’ (2) goodbye and upgrade to a newer Thinkpad. Personally I’m sold on that platform.
Thanks for the response.


When you installed (and reinstalled SketchUp 2017, did you right click on the installer and choose Run as administrator? Or did you just double click on the installer to get it to run?


This ain’t my first rodeo. :sunglasses:


What does that mean? It didn’t answer the question. I guess you have it under control so I’ll wish you good luck.


May not be relevant to you, but my spacedriver caused all sorts of problems on my PC as it was conflicting with my joystick drivers. It would cause lots of mayhem, in the end I just had to un-install it and now I only use it on my Mac.

If you have any flight simulator stuff, that can be an issue!


Just for clarity, as I’m not sure after reading your posts, @MikeWayzovski is correct. You must do things in the following order:

  1. Install SketchUp 2017 by right-click the installer and choosing “run as administrator “. Do this while logged in as your normal account, not the special Administrator account.
  2. Run the 3Dconnection driver installer. I don’t know whether this also needs “run as administrator” but it can’t hurt.

He is right that’s 3D connection’s installer looks for the folders that indicate what versions of SketchUp are installed and copies the driver files separately into each that it finds. So if SketchUp isn’t installed first, 3D connection’s wont find it.


It was my snarky way of indicating that I’ve done this dance around Windows 10s’ want of “Administrator” rights hundreds, if not thousands, of times. It obviously didn’t go over so well. I apologize. I wasn’t trying to be rude.


Often when people exaggerate their frustration they haven’t actually read what was asked.


So I ran the OpenGL Extensions Viewer when I got home. My T410 has an nVidia NVS 3100M/PIIe/SSE2 graphics processor. there was a lot of information but other than running OpenGL 3.3 None of it made much sense to me.


So after giving it some thought, I reinstalled (once again) the 3Dx driver 10.5.5. Still no go. It occured to me that I have a new (in the package but still an antique) Space Explorer. Hmm. I unplugged the Space Pilot and plugged in the Space Explorer and…wait for it…voila! It works with SketchUP 2017.
So one is now proudly occupying space on my desk and the other is…well…retired.

Thanks for the thoughts folks, It helped immensely in resolving the issue.


I figured that as well. Sketchup hadn’t been installed on this particular laptop before so there weren’t any “other” folders. The whole thing just threw me at the time. It was only after I tried a second device I had that I tumbled to the idea that the SpacePilot may be bad. It worked when I put it away last, or the laptop I’m using may not have enough umphh to push it. I’ll figure it out as I go along…again. My desktop systems will probably stay “put away” and I’ll use laptops going forward for portability.

Thanks for the response.


And if this is who I think it is, I’m back to using your book! :grin: Question is, in moving from Sketchup 2014 to 2017, do I need the new edition?


Yes. You should buy a new copy. :smiley: It won’t be any different than the one you have, though. :wink:

Not that much has changed between 2014 and 2017 as far as the basics go so you should be fine with what you have. Besides, I haven’t done an updated version…yet.