2D Export not working on Pro '19

I’m new to SketchUp. I have a provided model that seems to work well except when trying to export 2D images. I’ve tried PDF, jpeg, tiff, png. The PDF is closest to the model but for some reason removes the brick texture exterior. The other 3 lose all color info and seem to show just shape with strange coloring. I’ve tried changing graphics card to be dedicated to my NVIDIA as the program (and an older forum response suggests) but it didn’t help even after a restart.
Any ideas?

Exterior PDF.pdf (9.0 MB)

Most likely the model is inside out. Ie, all the faces are reversed.

If this is the case, you’ll need to reverse backward faces and repaint them.

Select a properly outward facing face that connects with backward face(s).
Right-click on this face, and choose “Orient Faces”.
(This should attempt orient all connected faces in the manner of the clicked face.)

What this method does not fix, you can reverse individually, via right-click, “Reverse Faces”.

If you model in monochrome rendering mode, the face fronts are white, and the face backs are dull blue.

View (menu) > Face Style (submenu) > Monochrome

Or using the “Styles” toolbar …


You can even change the monochrome face back style to magenta (as I do) to help better signal when faces are reversed.


Clicking the color swatch brings up the Choose Color dialog (shown from MS Windows) …


Then click the Style thumbnail after making changes to update the style your editing …


Notice how the update arrows appear if the style properties have changed?

1 Like

The PDF/EPS export from SketchUp exports a vector graphic image of your model so it ignores all raster features like textures, shadows, transparency and stroke-based line styles.

When you installed, did you right-click the installer and choose “Run as administrator” ?
If not, do so, and this time choose the “Repair” option.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.