2d dwg problem - plans and elevations overlapping

dwg
cad
import

#1

Is there a way I can open a 2d dwg file in SU and annotate, take measurements from etc. I’ve got as far as importing the file but its not importing correctly.

Afraid its not something I can share on a forum but happy to share with an individual if theres someone here who’s willing to help.

Much appreciated


#2

Could you provide more information about what happens exactly?

You can check this article about Importing and Exporting CAD Files for more info.


#3

Thanks filibis

There are multiple floor plans and elevations in the file and they become overlapped and not on the same plane for want of a better description.

Ive followed the importing and exporting cad files and the result is as described.

I’d happily share the file with you if you have the time to look.


#4

I don’t have access to SU Pro right now but i can take a look at in the evening if you share. You can take a look at this dwg import guide for tips in the meantime:

I’m not sure what causes that but make sure that they’re on same level in Autocad as well.


#5

When you import dwg files, they are placed centerd to the model origin, unless you have the “preserve original coordinates” box checked in the import options. Be careful with this, though. If the dwg uses very large coordinates, for instance from a map file, they might result to a model that is too large for the opengl display system to handle correctly.


#6

Thanks will share it with you later today. I’m trying out the turbocad free trial at the mo so will see how that goes. And to be honest, the drawing is a bit of a mess. its been added to and altered by several people over about 3 years. :rolling_eyes:


#7

Thank you guys. I’ve managed to get a cleaned up version of the file sent to me and all seems to be fine now. I notice that none of the dimensions or text have imported although they are on the file emailed to me. I can manage without them but is there a way to import these too?


#8

I’m afraid those elements you mentioned are not supported. There is a table mentioning this in the article i shared earlier.


#9

Oh yes of course.

Its fit for my purpose now anyway. Thanks again.


#10

This topic was automatically closed after 91 days. New replies are no longer allowed.