DWG or survey data not importing correctly

Hi, this is my first post. I did search for other posts related to DWG import issues, but they don’t feel like a good fit for my situation.

I had a topographic survey performed at my property and the company sent a PDF and a DWG of the survey data. I can load the DWG into the AutoDesk online DWG viewer and it looks fine, just like it should. Here’s a screenshot:

A - LIDAR data from NOAA. Survey company added this data to the main file.
B - topo surface model created from the actual survey points that were taken
C - Lines that the survey company added to the file for waterlines, buildings, etc. (not sure why they’re at Y:0, but I’m OK with it)

When I import the file into SU I receive a warning. This warning seems somewhat common from what I’ve found in my research when loading large scale data, like a land survey.


Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.

AutoCAD Entities Imported:

	Layers:		346
	Blocks:		14
	Arcs:		7
	Circles:		23
	Inserts:		15
	Lines:		488
	2d Poly-lines:	78

AutoCAD Entities Simplified:

	Coords out of range:	945

AutoCAD Entities Ignored:

	Images:			1
	M-Texts:			41
	Proxy Objects:		954
	Texts:			8
	Anonymous Blocks:		118
	Zombies and Others:	48

I do see in the AutoCAD Entities Ignored section that there are many objects that were ignored. That probably explains my problem, but I don’t know what to do about it! :smile:

After the import, I see the “NOAA LIDAR” data but the topo mesh is missing, these are probably the ignored objects.
**I tried to include a screen shot but for some reason “new users” can only have one embedded media item.

I’ll have a little bit of a challenge asking the survey company to “fix the file” because it loads fine in the Autodesk viewer. I’m hoping some of the experts here have some additional ideas or maybe can see the issue with the DWG file. I’ve attached the DWG file as well as the SU file with the imported models.

23033T1-1.dwg (3.7 MB)
survey data imported - bad.skp (637.5 KB)

Your SKP file looks like this

I saved your dwg file in dwg version R21 format - 2007
and after import it looks like this in SketchUp

with this info at import


Read this about Unsupported CAD Entities at import - Importing and Exporting CAD Files | SketchUp Help

There is also a problem that must be solved first: one or more of the drawings is inserted as an XRef and it is necessary to bind it/them if you want to be able to edit or import it in another program. How to bind XRef in Autocad > Help


1 Like

You can also check the data in Trimble Connect 3D Viewer (upload the .dwg, checkmark the file to see the details and open in the 3D Viewer):

From there, you could download as TrimBim and try to import that (It is possible from version 2023 to import TrimBim files, the format that Trimble uses for displaying data from all kinds of formats.
It will still import a long way from the models origin, but then you can move that more close to the origin.
Ran ‘Create from contours’ from the sandbox tools, but there might be better extensions out there:

From TrimBim.skp (5,0 MB)

1 Like

I found no surface in the DWG file, only the contours. Is it in the XREF that DWG TrueView reports as missing? The SketchUp DWG importer ignores XREFs so you would have to bind it in AutoCad before importing.

This topic was automatically closed after 186 days. New replies are no longer allowed.