2021 MSI Installation Folder Issue

Hi, I’ve downloaded the latest MSI available for SketchUp 2021 and noticed that the software is installed to C:\Program Files\SketchUp\SketchUp [SketchUpYear] rather than ‘2021’. It seems that within the MSI this property exists and has it’s value set to 2021 but it’s being ignored.

I’ve tried running the MSI itself and running it through MSIEXEC with the same result. The only fix I’ve found is to edit the MSI and replace all entries of [SketchUpYear] with ‘2021’, which appears to have worked.

Do these MSIs not get checked before being released? This isn’t the first one that’s been a bit buggy!

I logged a bug report about this a couple of weeks ago. I’m not sure when it will be worked on.

Strangely, the install works, SketchUp works, but as you saw the folder name is not correct. We do know to look for that in the future, but someone may have tested the MSI and thought that everything was working ok. That team put most of their effort into the EXE version of the installer.

I was thinking of doing the edit of MSI test you did, but was sure it would work, and so didn’t do the test.