2020 Arrays (Multiple Copies) Bug? Or Just a wrong setting?

Hi everyone,

I am not sure if this is a bug or if some default settings got changed once I went from Pro 2019 to pro 2020, but before when I was using the * or / modifier while copying an object, I could adjust and repeat this command to try out several values, and it would update the recently copied objects leaving me at the end with a single set of copied objects corresponding to the the last value I entered.
Now, it seems that it just creates copies after copies, which is a little cumbersome to remove, especially when you are just trying some numbers out.

Is there a setting I am missing buried in some menus somewhere is is it just that 2020 doesnt seem to handle that behavior very well?

Thanks,

Simon

I can’t reproduce what you describe, so I must conclude it isn’t SketchUp 2020 in itself. Could there possibly be a Windows keyboard setting affecting this, the way smart quotes mess up inches and the tab-to-focus setting interferes with spacebar on Mac?

I tried in Windows too, and the x or /continue to work like they used to.

Are you actually trying *, or did you mean x?

Well it always worked fine for me until I updated for 2020 about a week ago, and I dont recall having a windows update within that timeframe.
I always used *, just tried x but it is the same thing. Iterations stack in the model instead of just updating as it used too until I use another command.
Same behavior with / as well

you are making a ‘move copy’ first?

john

Move or Rotate, hitting ctrl for a copy, placing it then using * or / with the number of copies I want.

For instance if I do *5, I get my 5 copies
Before, I could hit *6 and get an extra one, but now, I get 1 extra + 5 on top of the previous 5 instances I already had.

Can you share a .skp file where this happens? Maybe set it up, do the copy thing and verify that it happens and then undo before uploading the file.

198_Ribs_Rock 2_ST_2020-03-11.skp (5.0 MB)

here my latest file.
Simple rectangles on the side are what I mean (did *5 and then *6)

I see your double stacked rectangles. I moved the top one over and painted it red. Then I made copies using *5 and changing to *6. When finished I only get a total of 7. I wonder if you have some extension doing this.

Did you use the Right Click Run as Admin method to install 2020?

1 Like

That’s quite weird indeed.
I use quite a bunch of extensions so that might take a while to troubleshoot if that is the case. However they were the same ones in 2019
Extensions can mess up with native skp functionalities? I was not aware of that

first suspect is vRay as your file is full on vRay attributes…

john

But extensions don’t travel along with a skp file! So if an extension is at fault, it would have to be one that both of you have installed else you wouldn’t reproduce the behavior.

Exactly! I see that his model included the additional copies but it didn’t happen for me when I performed the same task he describes. If it is caused by an extension, it would imply it’s an extension he has that I don’t.

Seems like V-Ray was the culprit!
Just uninstalled Vray and rebooted my system and now it is working properly as DaveR.
They had an update February 18th 2020 which is not installed on my 2019 version so that’s probably where it comes from.
Thanks for the tip! And for all of your support guys

I will contact Vray support to let them know

Without Vray_Stack Test 2020-03-11.skp (119.4 KB)

3 Likes

I misread your comment about “only get a total of 7”. Sorry!

1 Like

I understand your problem, I have the same bug, when I use move and copy, and add / and * does not update, I have come to the conclusion that it is a problem with vray, it appeared out of nowhere, update vray and reinstall it. the error persists. have you already managed to solve it?

Unfortunately not yet. It did disappear for a while, but I think it is a weird bug with interactions between vray and other plugins, on their own they are fine but with my full setup it starts doing it again.
Still unsure how the whole thing is working

Vray is the only plugin I have, it happens to me only with vray, maybe with laubwerk or skater it starts, since they interact with vray. I am trying to solve it by deleting temporary files from windows, maybe one of them is interfering. I leave you an example of the sketchup registry command lines.
Tool(MoveTool)
Undo(Mover)
Undo(Copiar)
Start(Matriz)Commit(8)
Undo(Matriz)
Start(Matriz)Commit(9)
Undo(Matriz)
Start(Matriz)Commit(10)
Undo(Matriz)
Start(Matriz)Commit(11)
Undo(Matriz)
Start(Matriz)Commit(12)
Undo(Matriz)
Start(Matriz)Commit(13)
Undo(Matriz)
Start(Matriz)Commit(14)
Undo(Matriz)
Start(Matriz)Commit(15)
File Save
next is when i start vray.

File Save
Tool(SelectionTool)
Tool(SelectionTool)
Tool(MoveTool)
Tool(MoveTool)
Tool(MoveTool)
Tool(MoveTool)
Start(Mover)Abort
Start(Copiar)Commit(37)
Start(Macro)Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(39)
Tool(MoveTool)
Tool(MoveTool)
Start(Matriz)Commit(40)
Start(Grupo)Commit(41)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(42)
Tool(MoveTool)
Tool(MoveTool)
Start(Matriz)Commit(43)
Start(Grupo)Commit(44)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(45)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(46)
Tool(MoveTool)
Tool(MoveTool)
Start(Matriz)Commit(47)
Start(Grupo)Commit(48)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(49)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(50)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(51)
Tool(MoveTool)
Tool(MoveTool)
Start(Matriz)Commit(52)
Start(Grupo)Commit(53)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(54)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(55)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(56)
Tool(MoveTool)
Tool(MoveTool)
Start(Grupo)Commit(57)
Tool(MoveTool)
Tool(MoveTool)
Start(Macro)Tool(MoveTool)
Tool(MoveTool)
File Save

do you use two languages on your computer?

No even though I could, I tend to always set everything computy to english.

The bug disappeared for a while and now it is back, not really sure why. I already contacted V-Ray about it and they said they weren’t able to replicate the issue.

Only thing they could suggest was to reinstall, which I did but didnt change the issue.