2020.1 Clipping Issues

I’ve been working on this sketchup file for a few weeks and did not have any issues with 2020. I upgraded to 2020.1 yesterday and now I’m having clipping problems. Is anyone else having these issues? In the past I would just use zoom extents and then zoom back in but that is not fixing it anymore.

image

image

Not sure how to insert images so hopefully this will work. the second image happens after one ‘click’ of my mouse wheel zoom. This is also happening with other files.

I haven’t see any change in clipping in 2020.1. Try switching the camera to Perspective. Does that help? How far is the model from the origin?

Clipping Plane extension, sorted.

Yes, perspective does fix it. But I have a hard time working in that mode. it’s about 127’ from the origin.

My main reason for this comment was prior to the .1 install, I did not have these issues so wondering if something changed.

Thank you for the suggestions and I’m sure that would fix it, but not looking to spend $50. I think I would go back to the 2020 version first.

That extension uses a send_action, which you could use to see if zooming in Parallel camera changes the position of the camera. This wasn’t the case in prior versions, where scrolling the middle button, just enlarged the view.
(Windows only)
Open the ruby console ([menu]Window->Ruby Console)
Type: ‘Sketchup.send_action(10624)’ and Enter
Check the position,
Scroll, then check again

here’s what I get. Not sure what I am supposed to do with this information. Thank you for your help
image image

You can go back to parallel projection after fixing the clipping. The clipping has been that way for most versions of SketchUp, and is easy to cause to happen. While in perspective, zoom into part of the model that is not closest to to camera (so that some geometry is behind you). Switch to parallel projection, all the geometry behind the camera is bound to be clipped. Zoom extents in parallel projection does work for me, so there may be something unusual about your model. Jumping into perspective and zoom extents will pull the camera back away from the geometry.

Was the geometry imported from somewhere?

The dir and up did not change, but the eye, did, so you where just scrolling in Parallel projection, I believe that it is different with prior versions. Not on Windows to test, though.
Do you have 2019 installed?

yes, I still have 2019 installed

I am aware that clipping has always had this issue, and it used to be not this bad and easy to fix by zooming extents.

so that was a great question. I had forgotten that in the middle of drawing this I had imported a caster from the warehouse for an unrelated base support I drew, then printed, then deleted. I just purged unused and then ran fix problems and it found many errors. Looks like the drawing is behaving better.

Do you remember the model in the warehouse? Also, it was a regular import, you don’t use Transmutr?

Here’s a likely candidate.
Looks pretty, until you turn on hidden geometry.


Another wreck by the same author.

There is a known regression in 2020.1. Hopefully we’ll see a fix soon.

Unfortunately I do not remember the exact one. Yes it was a regular import, I don’t know what Transmutr is.

There were two I tried. the first one was deleted after import (didn’t look correct) and I used the second one for the print. Looking at the 3d warehouse, this was the second one.

Interesting statement. I am still seeing a little weird behavior but it is not nearly as bad as it was before fixing the model.

That one looks nice.

Transmutr can import FBX and other formats, but can leave geometry far enough away to lead to symptom like clipping.

In 2020.1 (or possibly 2020.0, I’m not 100% sure) zooming in parallel projection moves the camera instead of just changing the size of the image plane. This makes it impossible to get the magnification you could in previous versions in parallel projection without seeing clipping.

Curious why you prefer working in parrallel mode… ? I have always found perspective mode quicker, more intuitive ( depth perception) and rarely encounter clipping problems…

1 Like

Hi,
This is my first post on this forum :slight_smile:
You could try this new plugin, free I believe. I haven’t tried it yet it’s very recent and I haven’t got any clipping issue recently :wink:
https://sketchucation.com/pluginstore?pln=s4u_Clipping_Camera
Let us know if this helps!