2018 File Preferences Not Sticking

I have custom folders set up to hold most of the sketchup preferences. This worked well in 2017 version. I cannot get these preferences to stick on 2018. I tried to establish preferred app for editing images and it defaults back to a blank insertion. For file paths, it keeps defaulting back to desktop or my documents folder.
Using Mac OS 10.11.6.

those preferences have moved for v18…

the new ones are stored in a .json files stored in the User folder with Plugins, etc…

it is easiest to redo them, then it is to convert the file formats…


Thanks John. This was driving me crazy today

Hey John, I found the files and was able to modify the document locations, but I cannot get my shortcuts to remain. I have to reset each time. Any idea what might be causing this?

Shortcuts are in the ‘SharedPreferences.json’ file…

mine look like this…

        "Settings": {
            "Num_Shortcuts": 33,
            "Shortcut_1": "0 0 0   selectSelectionTool:",
            "Shortcut_10": "0 0 0 K toggleDisplayBackEdges:",
            "Shortcut_11": "0 0 0 H viewShowHidden:",
            "Shortcut_12": "0 0 1 V pasteInPlace:",
            "Shortcut_13": "0 0 0 G makeGroup:",
            "Shortcut_14": "0 1 0 A deselectAll:",
            "Shortcut_15": "0 0 0 F selectExtrudeTool:",
            "Shortcut_16": "0 0 0 O selectOffsetTool:",
            "Shortcut_17": "0 0 0 w /Window/Component Options",
            "Shortcut_18": "0 1 0 G makeComponent:",
            "Shortcut_19": "0 0 0 u editUnhideAll:",
            "Shortcut_2": "0 0 0 L selectLineTool:",
            "Shortcut_20": "0 0 1 ± revertDocumentToSaved:",
            "Shortcut_21": "0 0 0 \u0004 /Edit/Context Menu Flyout/Flip Along/Group's Blue",
            "Shortcut_22": "0 0 0 \u0003 pageNext:",
            "Shortcut_23": "0 0 0 T selectMeasureTool:",
            "Shortcut_24": "0 0 0 S selectScaleTool:",
            "Shortcut_25": "0 0 0 R selectRectangleTool:",
            "Shortcut_26": "0 0 0 P selectPushPullTool:",
            "Shortcut_27": "0 0 0 Q selectRotateTool:",
            "Shortcut_28": "0 0 1 C /Edit/Context Menu Flyout/Edit Component",
            "Shortcut_29": "0 0 1 G /Edit/Context Menu Flyout/Edit Group",
            "Shortcut_3": "0 0 0 B selectPaintTool:",
            "Shortcut_30": "0 0 0 N newDocument:",
            "Shortcut_31": "0 0 1 H editHide:",
            "Shortcut_32": "0 1 0 H editUnhide:",
            "Shortcut_33": "0 0 0 D selectDimensionTool:",
            "Shortcut_4": "0 0 0 C selectCircleTool:",
            "Shortcut_5": "0 0 0 A selectArcTool:",
            "Shortcut_6": "0 0 0 M selectMoveTool:",
            "Shortcut_7": "0 0 0 z selectZoomTool:",
            "Shortcut_8": "0 0 1 Z viewZoomExtents:",
            "Shortcut_9": "0 0 0 E selectEraseTool:"

post yours if the format differs…


I found the file and it simply will not hold the changes I made. I was using F10-16 for some preferences to hide,paste-in place, etc. When I close out and then open back it simply doesn’t save the selection.

delete the line containing "Num_Shortcuts": xx, and restart SU…

if no change, paste one of your shortcuts that use Fnc keys…


How are you doing this? So far as I know, SketchUp 2018 does not allow you to choose a different folder for its .json preference files.

Also, how are you attempting to change the shortcuts? If you are hand-editing the .json file instead of using the Preferences window, it may be that SketchUp is overwriting your changes when it quits. Quit before editing the file, then restart SketchUp when finished editing. If you are using the Preferences window, then my previous pgf may be the explanation.

Also be aware that SketchUp’s convention for encoding function keys in the .json is strange. I have F2 set to flip along the red direction, and in the .json this appears as

"Shortcut_41": "0 0 0 q /Edit/Context Menu Flyout/Flip Along/Red Direction",

I know that in SU 2018 all character keys are encoded upper case (the shift modifier, third of the three 0/1 flags in the line, indicates lower-case (0) vs upper-case (1)), but I have no idea how F2 gets to be lower-case q.

I might not have clearly explained. I have my preferences on DropBox with all of our standards. I was able to make these adjustments from the preferences section and have them stick. As for shortcuts, for some reason, it will not retain the selections I have made. I looking at the .json file, I realized that the shrotcuts with Function Keys uses different coding.

Are you referring to the Files panel of the Preferences window? If so, there is no entry there for the folder that holds the .json preferences files themselves! I don’t think you can change that, and the keyboard shortcuts in SU 2018 are only in the .json files.

I realize that. In the preference section, I can define the the folder settings. That part was fine. You can also establish shortcuts. I have done that, but they wont stick. Now intersting thing here. I use an IMAC at work and MAc Book Pro, 2017 at home. The mac book is the issue.

Are they both formatted the same?
Mac journaled/APFS

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.