2017 stuck freeze 283mb file


#1

asus rog i7 7700 , 24gb , geforce 1050 intel 630 , wd black ssd nvrm 500gb ,

very good spec , still cant run file , any suggestions please!

The stranger situation is that my friend laptop lenovo yoga running on geforce 960m 8gbram i7 6700, and can work slow but better

Maybe os windows 10 home problem? Dose lenovo better then asus ?


#2

as a point of reference it would be very rare for any of my project files to be larger than 50Mb…

and I model large urban areas and detailed high rise developments…

and have been using SU since its release. just checked my server…

(0.7%) are above 50Mb and maximum is 160Mb .

(5.5%) are in the range 20-50Mb,

and I run an i7, 16Mb , GTX 1070 notebook…

maybe your file is just too big?


#3

How can i proceed , i tryed plugin reduce not helped, the problem my comp, all in circular ,

Dose my spec good ?

What spec for home pc will work such files?

Tganks


#4

you can open smaller files?

how large are they?

look at three useful plugins

GOLDILOCKS …PURGETOOL … CLEANUP


#5

I can open 80mb, can it be the wd black nvrm? Frind told nvme not steady ssd,

The lenovo have sata ssd

The more strange is i had my original asus rog 128 z400 sanddisk ssd 500mb w/r , and it worked slow , but workd

The new wd black working better but lot of freeze and must reboot.


#6

not a hardware expert… but is your pagefile large enough?


#7

Hi can i send u the file ?
Thanks


#8

Usually the reason .skp files are large is because of textures. Each texture can range from 1 KB (colors) to 25 MB (12K textures) and beyond. Each texture is stored in the drawing file and incrementally increases the file size. I’ve made models with tens of millions of polygons (it was mainly components) with no textures, but the file was only about 1.5 MB. Geometry probably isn’t the problem. I’d recommend trying texture resizer to reduce the file size. https://extensions.sketchup.com/en/content/texture-resizer

Maybe reducing the file size will help prevent freezes.


#9

Also, make sure SketchUp uses the dedicated graphic card. A lot of times, a Windows update messes with the battery-save-mode on laptops, which set the nvidia card aside.
Check yhe nvidia settings (rightclick on an empty space of the desktop.


#10

I knew there was a reason I loved working in monochrome. I feel validated. Plus no expensive printing or arguments with building departments.

I have been playing around with the concept of proxy textures. So the texture assignments only get applied when the model is pushed to the renderer or xrefed into a skp file where the proxies are replaced. I understand that I can use styles to control the display but I’m pretty sure having all the actual textures in the file will ultimately become a performance issue.

I know zero about programming so I have been trying to use some work arounds. I went as far as to create phony textures in my real model and then when I wanted color for presentation or rendering I loaded a bunch of swatches into a copy of the model and use “swap texture” to replace them all. You can imagine how cumbersome that became.

Trees and stuff get swapped when you send to tenderer. Why not textures too?


#11

Geometry quite often is the problem…

particularly overly detailed entourage like furnishings or landscape items…

Goldilocks can check LOD of geometry or textures…

if a big model performs OK in ‘Monochrome’, ‘Color by Layer’ or ‘Shaded’, but lags in ‘Shaded with Textures’ then it is more likely to be textures…

turn off ‘Use maximum texture size’ as an initial check…

if it lags in all, it is most likely geometry, both and/or Extensions…

the more things that want to auto update after every change the slower any model will perform…

so close ‘Outliner’, ‘Material browser’, ‘Scenes [with Thumbnails]’ , ‘Layers Panel’ , and ‘Components’…

turn off or remove all renderers unless your rendering…

un-croped screen grabs of kitchen appliances is the worst case I’ve seen lately…

john