2016 Pro trial won't revert to Make

I have tried and tried but nothing I do will work. I know for a fact I downloaded the make version and it still will not revert back to make after pro trial. I have been using sketchup for 10 years and have never had any problems like this. I have even tried on multiple computers and still the same problem. I read on hear that everyone blames the user for downloading the wrong file but I know I didn’t. Is there any way to download make without the pro trial period?

What does it do at the end of the trial period?

Everytime it says my pro trial has expired and asks for a license number.

Since you are certain you downloaded the Make installer, I don’t know what to tell you. That is the message Pro gives when its trial period expires.

@rabid_wolve, sorry about the trouble. This is certainly peculiar. Would you mind posting a screenshot of the welcome dialog when it’s asking for a license?

Hi Bugra

I’ve seen you respond to a few of these topics, and I’m having the same problem (and, of course, am on deadline). I can’t imagine I would have (knowingly) downloaded the Pro version of the software, as I don’t use it enough and none of my projects are commercial. The only thing I can think of is that I wanted to try Layout and thought the Pro trial would be the only way to do it.

In any case, my trial period has ended and it hasn’t reverted to SKP Make 2016. I’ve tried uninstalling SKP 16 Pro and downloading and installing Make again and have had no luck. I’ve looked in Library/Application Support/ and see no ‘SketchUp 2016’ folder. I can get SketchUp Make 2015 to come up, but now my projects have been saved from 2016 and aren’t backwards compatible.

You’ve asked others to PM you directly and I can’t figure out how to do that (forum noob). Can you help me?

Thanks in advance


What is the name of your downloaded install file?

You could try downloading from the http://www.sketchup.com/download/all page - it has clear links to what you are actually downloading. It seems that the main page often leads to people downloading the Pro version by mistake.


1 Like

@billgilman, Is the blue SketchUpMake screen from your computer? What happens if you click on Choose Template in that blue screen.

FWIW, with SketchUp Make, you’ll always get that window.

This worked! Thanks!

Same Issue here. I have used several versions of Sketchup. I just downloaded 2016. I verified that the file I downloaded was called SketchUpMake-en-x64.exe. I installed and immediately it says that my pro trial has expired and gives me no way to revert to Make. My screen looks exactly like the screenshot billgilman provided above.

ok, so when I followed the link to the “download all” page and chose the correct option, it downloaded Make and installed it properly.

When I initially navigated to the main page, clicked the Download" button and chose Personal Projects, it downloaded a file that is called Make, but actually installs Pro only. so it seems that something is wrong with that process and that the install file it downloads is named incorrectly.

the SU Pro version as well as the SU Make version do both run the initial 30 days as a trial of the Pro version.

The Pro version ceases to work further then, the Make version degenerates to a limited functionality w/o e.g. the solid tools, the vector data exchange filters, custom line styles, parametric components, report generation or the external 2D companion ‘Layout’ etc.

btw, Make version for non-commercial use only.

1 Like

Hy Everyone,

I have a problem and i hope that you can help me.
I use my company lap top and i can not install nothing on it.
So, I started using GSU 2016 from my USB, because i copied the whole instalation folder from my other PC.
Everything was fine until trial version expired.
Now, a can t start GSU 2016 make version, when i click to opet GSU i always need to input Serial number and licence key.

On my other PC i can use GSU make without any problem, and the main problem is that i copy the same folder on USB but i can not open GSU make, but only GSU 2016 PRO

So it looks like you installed SketchUp Pro instead of SketchUp Make. They both start out as SketchUp Pro Trial but only Make changes to Make when the trial period ends. Remove it, install SketchUp Make instead and you should be good to go.

I am confused about one thing, i copied the same folder to my USB, i click on the same icon on my USB, and i open GSU PRO.

When i do the same thing on my personal PC(from where i copied the folder), open the same folder and click on the same icon i start it without any problem.

In case that i install GSU 2016 PRO i should also get the same issue on my PC, or not??
Because that is the same instalation, just copied.

The SketchUp Pro 2016 and SketchUp Make 2016 are the same application. The installer for each one knows which version it is installing, and for Make it installs extra information so that SketchUp knows to convert from Pro to Make after the trial. Just copying the program over would miss getting the part that knows that it is Make.

Running the SketchUp Make 2016 installer would solve the problem.

By the way, if ‘GSU’ means Google SketchUp, the last version of that is SketchUp Pro 8. The one you are trying is Trimble SketchUp 2016, four versions later than the last of the Google ones.

What is GSU?

1 Like

Google Sketchup!

Google hasn’t had anything to do with SketchUp for about 7 years.