200MB of file size, 2GB after exporting to 3D max, is that normal?


#1

Hi everyone, I’m an IT person from the Architects firm and I’m not a sketchup user. I’m asking this question on behalf of my unskillful architect who lazy to do the research for her own. She has created a very huge file size @200MB and now it’s like unbelievable slow to run. To make it worse, my boss has asked another architect to do rendering in 3D max (for better result). After exporting process, the file turned to be 2GB and totally failed to open.

And my question, is that normal to create 200MB file for Sketchup?. If so is there any specific methods to export the file to 3D max?.

Some info regarding the file that may help:-

Edges : 55880976
Faces : 20780256
Groups : 280778
Layers : 165
Material :499

Thank you in advance guys.


#2

Wow! Where to begin?

Let’s start with the basics: 55+ Million edges is huge - HUGE! It represents a level of detail such that it’s highly unlikely that the smallest details will even be seen.

It is likely that a lot of your geometry simply isn’t needed.

But the first thing you should try is “Window -> Model Info”, then choose the “Statistics” pane (same place you got the statistics you provided), then use the “purge unused” button.

Everything beyond this is likely to be some kind of modeling/workflow problems, likely including:

Taking repeated elements and making them Components instead of Groups. More specifically, make ONE of the elements a component, then replace others with a copy of the component without using “make unique”. Once this is done, your “groups” count should go down and you should start seeing a count of “components” and “component instances”.

For repeated elements, components are far more efficient since multiple copies rely on the same definition and each instance (beyond the first) is stored much more simply as a reference to the component definition and the “transformation” matrix which specifies scaling, displacement and orientation differences from the original. If the geometry of the component is anything other than extremely simply, the transformation matrix of component instances takes up far less memory than a full copy of the geometry (which is what you get when you copy groups.

Beyond that? It’s hard to say specifically without seeing your model, but as I said above, it’s likely that your model is far more detailed than is necessary for any render that you intend to do.


#3

200Mb is typically on the heavy side, but hard to really tell as there could be many reasons for a large filesize. The model can have few polygons but contain lots of large textures.

This on the other hand is better data to evaluate by. This says the model has 20 million faces - which is large by any measure. The fact that the model is then “only 200mb” given that much geometry I’m guessing there is a lot of instances duplicated. That would optimise the filesize. Which in turn could explain why it’s 2GB when exported to a different format - you may be exporting to a format where instancing isn’t preserves and therefore the instanced geometry is effectively made unique.

One thing to try is to purge the model to ensure no unused geometry is left. Though that might not affect the export much - I’m not sure what the exporter do. Depend on settings.

Without knowing anything more about the model, a screenshot for instance (which you may not be able to provide due to confidentiality) it’s mostly guesswork.

I suspect that maybe the model is full of vegetation, cars, people etc? Can any of that be stripped? You might want to strip the SketchUp model down to the essential - terrain and building. And then use more efficient assets within 3dsmax for trees etc.


#4

You should start learning SketchUp, write some fancy ruby plugins and make her work better with a few clicks… you will love it.


#5

Hi there sjdorst, thanks so much for the reply and sharing some useful tips. I kind of know from the beginning this is matter of techniques and skills. I have forwarded the info to her and will update the outcome soon.

Thanks again sjdorst

Hi there thomthom, thanks for your help. Yes the file have a lot of vegetation, cars and peoples. I wish I could share the file in here. Well… I get one of the staff (she good in sketchup) help to get rid some of those and see what happen.

Thanks a lot.

Thanks Cotty for the advice. Sure I will learn Sketchup if I got time in future.


#7

Remember to Purge (Window > Model Info > Statistics)

Purge Purge Purge


#8

Old but maybe ideas help https://www.youtube.com/watch?v=hnhkei2dSrY