Zoom in/out reversed

Zooming in and out in my.sketchup with mouse wheel is reversed, compared with Desktop SketchUp.

Safari 10.1.2 (12603.3.8)

This (likely) has to do with your “Natural Scrolling” setting in your MacOS System Preferences. My.SketchUp inherits scrolling direction for Zoom from that setting.


Yes, until SketchUp 2017 you couldn’t set the scrolling to be natural on Mac, only on Windows. Checking the Invert box in SketchUp Preferences/Compatibility will make SketchUp match my.sketchup, and also all of the other apps on your Mac.

It did, but now I am not sure what direction ‘is natural’ anymore :slight_smile:

It took me a while to adjust. You have a lot of muscle memory telling you to scroll downwards to move the scene backwards, even if that’s not considered natural. The thing that makes it claim to be natural is that what you operate on does what it should do. You push away the scene, or pull it towards you. It’s only a problem in SketchUp because you’re actually moving the camera, which you don’t see as an object on the screen. That’s why the checkbox is Invert, because behind the scenes you’re inverting the behavior of the camera move.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.