Z axis location when grouping a cylinder

Good morning. For years I have been able to “group” a cylinder and have the axis point be in the center. Starting today, I am not able to achieve this and assume I accidentally made a change of something that causes this… I can’t find any way to set (or reset) the location back to the center.

The image below shows on the left a cylinder made before today. The one on the right in the same file was made today. Looking for help. As a log home guy, this is very important to me.

You were probably using a plugin to be able to automatically place the origin on the center of the bottom face of the cylinder.

If you use a recent version of SketchUp, you can draw the cylinder with the axes centered in the middle of the base… right click > Make Group

I wasn’t using anything other than skechup native tools but if you can suggest a plugin I’m happy to try and make the groups this way. It must be better than manually setting the axis point.

The plugin that works with these grouped cylinders needs the position to be centered. (Mad Beaver) I have just installed a trial of 2023 but can not see how this would mess up the sketchup functions.

Thank you for this video. It gave me hope but the end result was the same.

I right-clicked and choose to make the group as you have in 2023 and then built the cylinder. Double left click to open the group and the z-axis position is still in the corner.

Axes tools from ThomThom

Watch my clip carefully once again, especially at the 0.08 second. In what you showed, it doesn’t appear that you right-clicked and chose Make Group before drawing the circle.

I did right-click… my video capture was made with a program that does not show tooltips. As I wrote, I did right-click and chose to make the group. But I’ll do it again on my phone and upload this video to confirm that it does not solve the problem… that when double-click to confirm the axis position moves to a corner and does not stay in the center as I need.

I believe you will encounter the same result. Extend the cylinder and then double-click to edit the group. This changed 1 day ago

I am not saying that Sketchup changed. I am saying that I believe that I messed up a setting and it’s no longer working. I have been working in 2021 without issue and getting what I need but yesterday was the first time that I encounter that it does place the z-axis in the center of the extruded circle or cylinder.

I assumed it was a setting that I just have not been able to find.

I retested and it works ok. Did you install something (new extension, new plugin) yesterday?

in SketchUp 2022

yes, I installed 2023. I can get the right click to work making a component but not making a group. (Not in 21 or 23) I will keep hunting for a solution.

I have made this group the same way 10’s of thousands of times. My workflow has been the same forever… i just can not understand what I messed up.


I went over this with the developer who has done the most work with the Axes tool. Neither of us can remember a reason for this change, but there were various other axes related changes in 2023.

@mihai.s is using 2022, which is why the behavior is different.

I’m going to create a bug report about the change.

In the meantime, this extension will let you change a group’s axes to match the group’s parent axes. That will give you back what you need, without having to use the Axes tool:

https://extensions.sketchup.com/extension/afc38450-9d2b-41da-aaaa-27f250af73a6/eneroth-line-up-axes

The bug report I made is SKOR-17965 in our system.

2 Likes

We did track down what change was made, that introduced the problem. I will now be arguing to have that previous change be reverted!

1 Like

WOW! Thank you Colin.
I was thinking that the complication was self-induced. Happy to know this will be amended and back to the way it was working previously. Thanks again!

The other change was for what was thought to be a good reason. Me convincing people to change it back might not be easy! Also, such changes take a bit of time to be approved, implemented, and tested. It will be a while before you see any change in an update from us. You should try that extension, see if it will work around the problem for now.