X and * key not working for array copy

copy
move
array
movetool

#1

Hi people,

I’m trying to make 10 copies of a shelf. I use the move tool, hit the option key to copy then going by several youtube tutorials, I should be able to enter x or * then the number of copies I want, but when I do that I get “Invalid length entered”. I also tried swapping the number and x, so move, option, 5 or 5x and get the same result.
Using Sketchup Make on a Macbook Pro. Sorry if this is a stupid question or has been asked and answered before, I did look and couldn’t find anything!

Thanks people,

Shorty


#2

(1) If any shortcut is assigned to the X key, then you’ll need to use the asterisk (*).

So,

(a) select the object(s)
(b) activate the MoveTool
© click the base point of displacement
(d) tap the key for copy once (CTRL on Win / Option on Mac)
(e) begin moving in some direction
(f) either type the displacement followed by ENTER
… or click a second point
(g) then, (without leaving the tool) just type xn (*n), where n is an integer of the number in the array, and then ENTER (again).

If you are moving just single groups and component instances, you do not need to use the SelectionTool before activating the MoveTool. The MoveTool will select a single (group or component) instance, if the selection set is empty, with the first click for the base point, if the hovering for the click lights the instance first. (Ie, so the MoveTool has a “hover select” built-in.)


#3

Brilliant, thanks Dan! I was skipping stage (f) was the problem.

All the best