Wrong RBZ in Extension Warehouse


#1

I have just updated my extension and it has been approved (extension warehouse says correct new version number and date) and yet when you install from extension warehouse it installs the old version. Is this a bug or does it just take time to update? (Extension is ADC Sketchup)


#2

That didn’t happen to me yet. Since I as normal user/developer don’t have a better idea than you of what was going on, I think it’s best to have someone from the EWH team take a look at it. @ChrisFullmer


#3

I think it’s just that you didn’t bump the version number in adc_sketchup.rb–the latest one still says “1.0.0”.

When you install it in SketchUp, are the new features you added available?

Paul


#4

That’s true, I have forgotten that - although the code that gets installed in the plugins folder is the old version, and new components and features are not present so ti is very much the wrong file that is being downloaded.


#5

Try downloading the RBZ with a browser instead of SketchUp. You should get a file named adc_sketchup_2.0.0.rbz. If you unzip that, is it the code that you expect? If not, I think you just need to submit another update.

But if it’s different code than what was installed through SketchUp, we’ll investigate it as a bug.

Thanks,
Paul


#6

I get a file called adc_sketchup_3.rbz with the wrong code (Version 1.0.0)!


#7

Have just submitted another rbz with the version number corrected - don’t have very high hopes though!


#8

Hi again. Yep, something is definitely wrong. I tried publishing and approving it and I also still get the old RBZ file. Our web team is investigating it and we’ll approve it as soon as we can.

Thanks,
Paul


#9

Hi,

Sorry about the delayed response on this, but I wanted to let you know that this issue looks to be resolved. I just tested it and confirmed that I’m getting the latest version, which is adc_sketchup_2.0.1_1.rbz if you download from a browser.

Let me know if you find otherwise.

Thanks,
Paul