Windows 11 Layout Default Folder Bug

Recently updated to windows 11.
Layout has a strange bug where I cannot add any folder locations in the Preferences > Folders window.
If I click on the + icon I get the browse for folder popup window but it is blank with only a single folder called desktop. Refer the attached image.

Not a major issue but a bit annoying.

When you click on Desktop, does that expand to show something like this?:

Hi Colin,
Sorry for the late reply I had to go away for a few days.
No, clicking on the desktop icon does nothing but highlight it.
It’s a strange one for sure.
If this information is helpful this was a clean install of windows 11 not an upgrade over windows 10.
And the Sketchup version I installed was whatever the latest pro version was last week.

Bump on this, I am also experiencing the same issue and I would say it’s more than a bit annoying as it has locked me out of our company shared (through onedrive) templates and scrapbooks

I have tried an uninstall/reinstall (including scrubbing all the sketchup folders after uninstalling)

A fix would be greatly appreciated!

I chatted with a colleague in Support, and he has seen this issue before. I gave him a link to this topic, and he will drop by later today, when he is free to do more testing.

Turns out my colleague doesn’t see the issue.

What menu do you see if you right-click on the Desktop entry?

I get the standard windows context menu

Not all my colleagues seem to have this issue, I wonder if it is something about mine and @benoldays machines have in common? I’m not sure how to compare that

Just to note, I have tried navigating with arrow keys inside the ‘browse for folder’ dialogue but I can’t get any more than the desktop folder, so it isn’t that the others are just hidden

I noticed something. Your Desktop icon is a generic folder, not the special desktop icon. Also, when I right-click I get to modify the properties control panel, I don’t get the stand set of options you’re showing.

Try the Copy as Path option, and see where that Desktop folder is located.

Hi Colin

That’s a great spot, the file path is pointing to the desktop folder in our corporate onedrive:

“C:\Users***\OneDrive - ***\Desktop”

Hi guys.
No fix to this so far I see.
Just a note on my end I am also using Onedrive, which does strange cloud things I don’t understand to my desktop across multiple devices.
Could that be the potential issue? Having the cloud based file system?

Hey @colin just looking to resurrect this thread as the issue is still there, do you think the desktop folder location is an issue, and if so is there a way to change where layout looks for the desktop?

Many thanks

I don’t know. @Adam or @trent may have ideas.

We have one similar case with a different app and when we installed SketchUp (&LayOut) to test it showed the exact same issue.
Other users in their company with the exact same setup and machine specs did not, so it’s most likely a specific user thing.
Do you have another account on your machine?

Hey Mike, I have the option to sign in as a domain-joined user (but never have done), but my user is actually local on this machine