Why is the playing field so huge in SketchUp?

I’m using the the Shop (web) version of SketchUp. My question is why is the playing field so huge that you can literally get lost in it? I’m trying to design a house, not an entire city. Usually I can orbit around until I see the guide lines converge. Not this time. Is there a way to limit this vast virtual expanse. I’ve been searching for 10 minutes and I haven’t found my model yet.
Also why does SketchUp think that if you accidentently click on empty space, you want to be shot a half mile away from your model. How is that useful to anyone?

Click the Zoom Extents button. No searching needed.



Thanks Aaron!

All I get is this. Did my model crash?

Download the .skp file to your computer and share it with us so we can see what you’ve got and try to help you out.

1 Like

The program won’t let me. The file size is 24MB and it says its too big to upload.

Upload it to DropBox or WE Transfer and share the link.

It did crash. I have downloaded a previous revision and hope to have it saved to 3D Warehouse. When I was unhiding all my hidden appliances, it crashed again.

Without seeing the file it’s pretty much impossible to tell you what the issue is.

It is in 3D Warehouse. It’s Indoor Garden House 5 by Robert Lever. Hopefully it arrived intact.

OK. So I find this dated today.

Lots of clutter from guidelines.
Screenshot - 5_14_2023 , 6_07_57 PM
Some incorrect tag usage. All edges and faces should be untagged.

Looks like you could do with learning to use groups and components. All of your geometry is loose which makes working with the model more difficult. The green faces (my default back face color) are all incorrectly oriented. There should be no exposed back faces

Beyond that I’m not finding anything that ought to make SketchUp Go crash a;though I suppose it’s possible that your computer or the graphics card is struggling.

You could also turn off Profiles in your “Architectural Design Style1”.

And some of your scenes. One of them points to the vast gray abyss!

What @3DxJFD wrote is a good idea. With profiles off the graphics card won’t have to work so hard.

Thanks for the help. I’m not sure how any edges or faces got tagged. I think I tagged a few components when I started months ago. I’m also not sure how faces get turned inside out. I usually work from top down, outside in. Do the back faces act any differently? I did have several groups at the start, but they got to be a bother, so I exploded them.
I hope its not the computer, It s less than 2 years old, I has an upgraded graphics card and a ton of memory. SketchUp does struggle with the model, and freezes up when it saves every two minutes or so.

So if I turn on “View Hidden Geometry” this model starts to lurch on my computer. If I triple click any geometry it freezes SU. The triple click problem happens because all contiguous geometry is selected - which is basically everything.

When you don’t create groups or components geometry can merge:

Maybe you merged geometry when you were exploding previously?

It seems, as @DaveR wrote, that you’d be better off using groups and components. Merging problems would be reduced, organization would be improved. You could also use tagging to easily turn visibility on and off - that’d be useful!

Edges and faces inside groups and components that you explode will inherrit the object"s tag. That is how you end up with tagged edges and faces.
Lots of guides in your model may be the cause of problems when orbitting.

That’s one of the worst mistakes you can make, loose geometry will get glued to any other loose geometry you could end up with a big bunch of everything and fixing it could take several hours if not days, what was actually bothering you with the groups? If you name every group and component right after making them you can find them easily on the outliner tray, even if it’s a group inside a group inside a group… just with two clicks you can get inside the group to edit it. But you must be tidy from the beginning specially if you’re working with a big project.

To help achieve your goals, some time spent at the SketchUp Campus and at the SketchUp - YouTube channel will be very worthwhile. Both sites are from the SketchUp team. On the YouTube channel, pay attention to the Square One Series. It covers the basics for each tool.

You can change your Autosave intervals.

  1. Go to Window>preferences
  2. Go down to General
  3. Under the “Saving” section tick Create Backup & Autosave and then change the Frequency to 15 minutes.

I used to disable auto-save and simply click CTRL S when I finish an important section, but that was when SketchUp and computers were a heap slower. Now I simply use the recommended settings (10min), and I never notice any lag… BTW I open and leave multiple large models open all day and night without any issue.
I also don’t use the 3Dwarehouse as large textures and heavy polygon count components can be added in minutes without you knowing; these slow you down.

Groups, components, scenes and tags are the keys to seamless workflow in SketchUp. If you don’t want to learn them buy a plugin that automates them.

Why hasn’t this issue been fixed… it goes against everyone here’s best practice advice and yet it is embedded in the SU code… it must be the biggest Gotcha for new users in SU