Why can't I make a grouped object Unique

Hey guys and gals,

Is it me or is the new 2023 Sketchup version different to 2022 regarding grouping geometry and easily having the option to make it unique? - Yes my 2023 Sketchup is also updated being that it is the 21st of March.

I’ve been using SketchUp for 3 months and have practised and observed from others that when I have to copy geometry that is not a component, I am always able to make it unique.

NOW… yikes, now I have to make my geometry a component that then needs to be grouped (because it’s a developing floorplan). From apply the advice from the below link = only then does the “Unique” tab appear. - For the purpose of creating a developing floorplan that will be edited, creating any copy to be a component and then to group it back, doesn’t make any sense to me.

I’ve also checked out: Make Unique Tool - and tried it out, but once again - my copy was changing from my original model, which is not what I wish to do.

If anyone could kindly suggest how I can copy grouped geometry that will not be linked to the original, that would help me out.

Kind regards


Make Unique applies only to components and is only available if there’s already more than one instance of a component in the model and your selection set is less than all of the instances of the component.

If you want a group why are you starting out making a component? Just make a group instead.

Your workflow doesn’t make any sense to me, either. Seems like you need to go back to the basics.

To help achieve your goals, some time spent at the SketchUp Campus and at the SketchUp - YouTube channel will be very worthwhile. Both sites are from the SketchUp team. On the YouTube channel, pay attention to the Square One Series. It covers the basics for each tool.

Groups automatically become unique the moment you edit them in any shape or form - this may even be as simple as renaming it or painting a face

The solution is to make a copy and then edit it - the instance will become unique

Even as simple as opening the group and closing it again.

1 Like

Dear Elmtec-Adam,

Thank you for responding.

I completely agree with your statement. I have been using SketchUp for 6 months and this process that you have described has worked for me until the 2023 update back in Jan/Feb.

Strangely, I noticed that when I would make a copy of a group, the “Make Unique” tab would not be there.
Down below I have a demonstration video of this.

Yeah, let me know what is going on.

Kind regards


Make Unique only applies to components.

1 Like

The make unique option is only there for components - editing a group automatically makes it unique.

If you look at the entity info , it will show how many of a specific entity are in the model.
Double clicking into the model as you have there , made it unique will show “ group (1 in model) “ for each of those windows.

Immediately after copying it will have said “ group (2 in model)

1 Like

Groups are unique, you don’t have the option to male unique something that already is, you must be confusing groups with components, components are all instances of an object, so when you edit one all the other instances will be edited as well. It doesn’t have anything to do with the sketchup update, it’s always been this way.

On your model convert the object you moved to a component, right click, create component, put any name you want or leave it with the default generic name, then make copies of that object, get inside the component and make any changes, all the copies will be changed as well, now if you right click on one or more components and right click you’ll have the make unique option.

1 Like

Groups are not unique until you edit them, they are instances of each other.


Just to make thing clear (or more confusing :wink: ):

Copying a group in SketchUp will create a group that shares the same definition. So these needs to make them unique, however there is no “direct” GUI command for it.
SketchUp implicitly makes group unique when edited from the GUI, and from a user point of view groups could be thought of as always being unique.


Edit: Adam just mentioned, while I recorded… :blush:


Oh, I see.


My apologies. From what you’ve just said, I’ve just realised that when I was learning on the job that I was told to only group geometry/models as components and not to use the group tool, which only then allowed me to see and use the “Make Unique” tool.

I see now.

Thank you for your help.

Wish me luck with my ongoing self-teaching sessions. :smiley:

Kind regards



Thank you for making me realise what I was doing wrong.

Kind regards


Absolutely brill.

Thank you for explaining.

I was taught on my job to only use the component to group models or geometry.

Now that I’m teaching myself again from scratch, THIS MAKES SENSE as to why I could only see the make unique tool when I made things as components.

Thanks for your time. I really appreciate it. :smiley:

1 Like