Why can't I load these .skm files?

A number of companies provide material textures in .skm format, but so far I can’t load these.
I tried the pointers in this related post but when the SKM folder is opened it appears empty, even though it’s not.
I’m using SU2020Pro on Windows 10 and trying to load an SKM file for “Lysaght Custom Orb”.
My materials folder is at:
Users//AppData/Roaming/SketchUp/SketchUp 2020/SketchUp/Materials/Lysaght Custom Orb

Any suggestions much appreciated

Can you provide a link to the source for the files?

Sure, it’s the third line item in this list:

Hmmm… Exactly what steps did you use to add the materials? I made a folder for the materials folders I copied from that ZIP file.
Screenshot - 3_23_2021 , 5_04_35 PM

then copied and pasted the folders from the ZIP file into that folder.
Screenshot - 3_23_2021 , 5_05_23 PM

since SketchUp was already open I went to the Materials panel, clicked on the Details menu and select Open or Create… Then I selected the LYSAGHT MATERIALS folder. That showed all the sub folder. Opening the one I think you referred to gives me this.

1 Like

OK problem solved, I was close but missed a key step.

A related question if I may: is there an advantage of skm files over bmp or jpg textures?

many thanks!

1 Like

Which step did you skip?

.skm files are material files in SketchUp. They contain the image file along with information about the dimensions of the texture so it gets applied correctly in the model. You can’t just put raster image files into a folder and have SketchUp read them as materials. You can import the images and use them as textures which you can then save for later use but you’d need to import them one at a time and set their size. No point in doing that in a case like this since someone else has already done the heavy lifting for you.

Ah, OK, skm files rule … :slight_smile:

a bit embarrassing to admit but I was thrown by last step - when I clicked on Custom Orb directory it showed no entries. The step I missed was simply to ignore the empty folder and hit “Select Folder” anyway … duh!

1 Like