Why are my designs sliced as solids in 3D printing slicers?

I have no idea what is going on with this, no idea what to look up to find answers, so I’m going to ask by myself.

I am relatively new to 3D modelling, and made a mount for a motor using Sketchup. When I loaded in this model to print and sliced it, I previewed what it would look like only to realize it has made the model completely solid. There is a hole for the winding and axle to stick out of in the bottom and it is meant to allow the motor to slide into it, front-first. This should be a slicer issue and I’ve posted it there, but I only have this problem with models I make myself. If I were to download one off of Thingiverse, it’s completely fine and prints as it should. Is this an exporting issue on my end, is this an issue with Sketchup, or is this an issue with my slicer (Cura 4.6.0?). Running Sketchup Make 2017.

Since I can’t put more than one image, this will have to do for now. This is what the model looks like and the slicer just completely ignores the holes.

As you’re new to the forum, there’s restrictions on how many files you can post. When you are able to upload it, can you share your SketchUp .skp file too.

Here it is. Thanks for your help.
mount.skp (1.2 MB)

I made something like you showed, and it was fine in Cura. Then I tried your model, and it’s fine too. Only thing you might do is to model it at a larger size, then get Cura to make it be the right size. At 18mm across that makes some of the geometry be fairly small, which could lead to gaps.

Here’s the two together in Cura.

I couldn’t get it to fail here. You have a nested component and I exploded that so it reported as solid. Both that and the original one worked ok, exported as stl to Cura. Then I noticed that SketchUp 2017 doesn’t have stl export. Which format are you using and can you share that file too please?

I saw several potential issues with the file you posted. Foremost, the contents are not a SketchUp solid, so it is uncertain what a slicer will do with them. To get a solid, you should

  • explode the (unnecessary) component that just wraps another component
  • examine that component using SolidInspector 2 to see why it is not a SketchUp solid.

Regarding the second, it seems that somehow the outlines of the inside top and the hole through the bottom are messed up so that they look like surface edges. Must be something to do with how you drew them - perhaps the size. You should draw at an enlarged size (e.g. use meters as if they are mm) and then tell the slicer the units are mm (.stl files are unitless - the slicer doesn’t know unless you tell it).

Here’s a repaired version in which the object is a solid:

mount.skp (1.3 MB)

I exported from SketchUp Make 2017, using the STL extension, as ASCII and Binary, and both still worked in Cura.

Note that I didn’t do any fixing of the file, and still Cura coped.

I’m not sure how to get the STL extension on my version, but if the newer versions come with it, I’ll just upgrade to that, no big deal. I use .DAE which is accepted by Cura as well. I have converted it to .STL before to see if that would make a difference, but since the original format was .DAE I figured it wouldn’t, and I was right. Also, it looks fine on the buildplate, but try slicing it and going to the preview tab. Mine turns solid. Anyway, here is the model.
mount.dae (38.5 KB)

I get a solid block when using DAE here. All the holes are filled in. Well not totally solid, but it’s not right.


Ah ok, so it’s the DAE format. Do you know how to get the STL extension working?

You could use SketchUp Free to convert it.

The dae has the same issues as I noted about the skp.

Thank you for all the insight.

Ah thank you. How do I get my hands on the STL extension?

When rotated in Cura to be the same orientation as SketchUp, the DAE export is completely solid after slicing, not just striped as above. That’s for the version I repaired in SketchUp (just exploded the internal component) and also the model @slbaumgartner posted too when exported as DAE.

mount_gm.stl (14.9 KB)

Here is the STL extension, it does work with SketchUp Make 2017:


Thank you so much. You just made my night for real. I really appreciate it.