Which hosts/IPs to allow through Proxy for license authorization/activation

They are not longer sold. They will continue to work, as long as there is no nuclear attack or something.

@MikeWayzovski Thanks for clarifying that - I was wondering about that myself. And it is probably more likely for the pandemic to mutate into a zombie strain… at which point all bets are off regarding Sketchup working or not.

@KyleWhite We also whitelisted *.sketchup.com as well – I don’t actually know if this is necessary or not, but I have this allowed through my proxy and I am able to connect to the license server.

When you run Sketchup on your own PC (and it works), does it (or did it) prompt you to log in to Trimble? If it doesn’t, then it means it might be accessing a different network location than the regular SketchUp Pro, which requires logging in to Trimble in order to activate it.

We’ve whitelisted *.sketchup.com too; nothing shows as blocked anywhere along the line. I’ve even run Wireshark and noticed that the software goes to a few other URLs and I’ve whitelisted those too. Still no luck.

When I ran it on my PC, it auto populates the ‘classic’ license fields, hangs for a second, then just opens the application as normal.

On the proxy based machines, it auto populates the license fields, then hangs… and fails with the screenshot above.

Thanks for your responses so far!

Are the ports required by network licensing open? (5053 and 50530)

Worth checking if you have a security solution that is blocking certain User agents, the web browser-based parts of SketchUp are using Chromium.

They might produce a similar type of error along the lines of what you are seeing.
This would manifest itself also with 3D warehouse and extension warehouse also not functioning.

Try logging in with a trial account to bypass the network license section and you can get to those areas using the internal browser, you may be able to rule that out as a possibility for error.


We are facing this issue, our security solution is blocking the license activation due to the user agent being chrome version 64… Do you know if there is a way to bypass this? Can we manipulate the user agent somehow?


I couldn’t find a way to bypass it within SketchUp itself, the last person I spoke to with this issue removed the user agent blocking from their security - as it turned out it actually solved some other problems their users were facing in other software too.

1 Like

We have a customer case going on currently, and they are going to try what Adam was talking about, and that is to let *.sketchup.com queries use the lower Chromium user agent.

I’m curious, is there a global IT push towards setting v88 of Chromium as the minimum version that is allowed through firewalls?

Does SketchUp needs to be closed when editing the .json file?
WILL it gets rewritten upon closing again?

@chasegrisby56 Yes, Sketchup will resave/overwrite the .json file when it closes, so Sketchup should be closed when editing the file. Otherwise any changes made will be lost.

1 Like