When I right mouse click the selection box does not appear


#1

When I Drag the mouse to expand the selection box , selection box does not appear. It will highlight the objects, but I can’t see the selection box


#2

I had this happen on my system. at just about the exact same time that the ‘space bar’ started to act as the keyboard shortcut for the Geo Location panel (as opposed to the ‘Select’ Arrow icon).

I was more worried about the ‘space bar ≠ select arrow’ issue and started to troubleshoot that. and ultimately contacted the SketchUp Support folks for some ideas on how to fix the problem.

BUT, I ultimately fixed both of these problems by installing the SketchUp 2015 release onto my machine. . . which had the miraculous timing of showing up within a couple of days of me noticing these problems. . . So my first question to you is what platform are you on, and what version of SketchUp are we talking about here?

I was running SketchUp 2014 Pro, on a Macbook Pro (OSX Mavericks), when these issues showed up. Does this combination run true for you as well?


#3

excerpted from an email reply I received from SketchUp Support Team…

(Quick summary: Selection Behavior (are odd), and might be related to Fast Feedback or, a Hardware Acceleration issue). . .

Hi Jim,

Thanks for your note. I see you’ve bumped into several issues in SketchUp and are concerned about what may be causing them. I have definitely heard of a couple of the issues, though the selection behaviors are odd.

Regarding the Spacebar behavior, this is a result of the shortcut settings in OS X, o work around this issue, press Ctrl+F7. If you’re using a Mac laptop, press Ctrl+Fn+F7. This will change the setting from using keyboard access affecting All Software to only working in Text boxes and lists.

The missing bounding box sounds like an issue with Fast Feedback or possibly hardware acceleration being enabled. Try turning off Fast Feedback and test to see if the behavior remains, if so then you may need to disable Hardware Acceleration in the same location. To turn the Fast Feedback and Hardware Acceleration options off:

  1. Open the “SketchUp” menu.
  2. Click “Preferences”.
  3. In the left pane, click “OpenGL”.
  4. In the right pane, clear the “Use Fast Feedback” check box.

You can turn Hardware Acceleration off in the same location.

It’s possible that this was also the cause of your selection issues so you may wish to test those as well and see if the problem remains.

There aren’t really any known issues with SketchUp 2014 beyond the incompatibility with Yosemite, though some users do bump into issues with some 3rd party extensions. If you’ve installed any Extensions you might try disabling Ruby or selectively removing them to see if it affects performance. If you wish to disable Ruby and see how SketchUp behaves you’ll find steps for disabling in our Knowledge Center here: http://help.sketchup.com/en/article/1700320

Be sure to re-enable Ruby following the same steps if you need to access it again.

Note that we have just released a new version of SketchUp today which has a number of performance improvements along with some new features and assured compatibility with OS X Yosemite. Your Maintenance and Support Plan is current so your license was already upgraded for the new version. You can download SketchUp Pro 2015 here: http://help.sketchup.com/en/article/115548 […]


#4

Typically the invisible selection box problem is a symptom of inadequate OpenGL support in your graphics card driver.

  • try updating the driver (download and install the latest version for your card from the card chipset manufacturer’s website)
  • if you are using a Windows laptop with an Intel processor, check in your graphics card control panel 3D settings that SketchUp is using your graphics card instead of the integrated Intel graphics chip.
  • In SketchUp you might also try turning off Fast Feedback from Window menu>Preferences>OpenGL.

Anssi


#5

Thanks, updating the drivers worked.