When I open the bucket materials, Sketchup pro 2021 crash

When I try to add some materials whit the bucket, Sketchup crash, even if the model is a new one and just have 1 element.


Translated Report (Full Report Below)

Process: SketchUp [2520]
Path: /Volumes/VOLUME/*/SketchUp.app/Contents/MacOS/SketchUp
Identifier: com.sketchup.SketchUp.2021
Version: 21.0 (21.0.392)
Code Type: X86-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2023-07-30 16:42:03.4352 -0400
OS Version: macOS 13.4.1 (22F770820d)
Report Version: 12
Bridge OS Version: 3.0 (14Y910)
Anonymous UUID: 9681A69E-2B99-5CB6-DBA5-15599A109AD9

Time Awake Since Boot: 1800 seconds

System Integrity Protection: enabled

Crashed Thread: 0 CrBrowserMain Dispatch queue: com.apple.main-thread

Exception Codes: 0x0000000000000001, 0x0000000000000000

Application Specific Information:
abort() called

I wonder if SketchUp 2021 is compatible with your version of MacOS.

I suspect @Anssi has hit on a likely problem. SketchUp 2021 does not support the OS version your indicate in your forum profile.

I was using sketchup pro 2021, model de building add material, but the I install Vray 1.6 for sketchup 2021 and the crash started.

I reinstall both programs, but even with a new model, the crash continued

Please tell whit what version be a better fit with Mac Intel i7

Are you sure about that version?

For Mac OS 13 you need to be using SketchUp 2023 (previous versions of SketchUp do not support Mac OS 13) and the current version of Vray. Version 1.6 is ancient.

1 Like

Plus, is it 2021.0 or 2021.1 you’re using ?

back then, there was a big bug on some macs, it got solved in 2021.1
basically, trying to use materials made SU crash on nome machines. The workaround was to right click on SU in the app folder, show content, then look for macos and launch from the executable inside.

a fix was quickly deployed, then later 2021.1

Sorry, the vray version is 6.1

the .dmg file says “2021.0.1”

That’s definitely different that 1.6.

So not 2021.1. No matter, even 2021.1 doesn’t support the Mac OS version you are using.

How is that “not support” but I made a 3d model and apply materials a week ago.

is the 3 elements that make the crash? vray 6.1 + Mac OS ventura + Sketchup pro 2021.0.1?.

so, if I upgrade to Sketchup pro 2023, the problem is solved?

Maybe. Everything needs to be “right” in order to troubleshoot your problem. Make sure the SketchUp and Vray versions are right for the OS and then work from there. Make sure the SketchUp model is clean (share it if you want us to look at it and check it over for you) and make sure you are doing everything else correctly.

it means the devs didn’t test it on this OS. therefore if it crashes, well it’s on you. If you want a supported version, you’re supposed to switch to 2023 or rollback to an older OS.

then again, it doesn’t mean that SU won’t work, that it won’t start. as you said, you used it. but crashes and bugs between SU21 and osX13 won’t be fixed.

I’d say SU pro 21.0
maybe a combo of some sort, but mostly SU21.
Releases notes states that 2021.0.1 fixes the colour palette bug. but in your case you still have it. Either it’s the other colour palette bug fixed in 2021.1 or it’s a compatibility issue. either way, your version has a problem.

By the way, You also have a macos update, it’s 13.5 now :wink:
I don’t think it’ll fix your problem, but hey, never know.

well yes maybe, if not we would have ruled this out.

Your first step would be to simply re-download the lastest Sketchup Pro 2021 here

and simply put in in your app folder instead of the current one.

you can also install 22 or 23. you can have several Sketchup installed at the same time on your machine.
(off course, the only officially supported one is 23)

How can I send u my model?


HAHAHAH thanks for the update, I just saw it, now u mentioned

I think that I would update to SU23, and if I have the same bug, I will reply to this post!!

thanks for the support

Upload it ina reply here. If it’s larger than 16 Mb, upload it to DropBox or WE Transfer and share the link.

One of the fixes in 2021.1 was this one:

  • (Mac) Fixed a problem where materials in the app bundle that were not writeable would cause a crash.

It doesn’t clearly explain what actions would cause it to crash, but one of those was when you ran SketchUp from the disk image, which is the case for you:

Path: /Volumes/VOLUME/*/SketchUp.app/Contents/MacOS/SketchUp

You could update to 2023, but you also could first update to 2021.1.2, which includes the fix for that crash. Here’s the Mac disk image:


Make sure that when you mount that disk image, you then drag the SketchUp 2021 folder onto the Applications alias, to copy it to your internal drive instead of running it from the disk image.

After it is copied, eject the disk image, then run SketchUp from inside Applications/SketchUp 2021/

When you run SketchUp that way, look in the Dock to see how many SketchUp icons show up. The one that looks like this, with the black dot under it:


is the SketchUp you just opened. Any other SketchUp icons in the Dock are likely to be pointing to the wrong place. You should remove those from the Dock so that you don’t accidentally open them in the future.