What on earth is going on?!?

2d
lines
faces

#1

I wonder if anyone can help… I’m working on some 2d elevations and plans on SketchUp Pro.
As the drawing has progressed I’ve noticed that in places the lines are ‘thinning’ or becoming invisible altogether whilst still actually being there.
Also, faces without border lines have started to appear randomly in the drawing. Can anyone explain why/what/how this is happening?
Many thanks in advance.


#2

Working in 2d within a 3d application can be tricky.
We would need to see the model to tell you exactly what is going on.


#3

Thanks for your reply - these are 2d drawings only. There is no model. We are only working on the top plane.


#4

Perhaps, but it is still within a 3d space and you are possibly overlapping things.


#5

Do you mean overlapping lines on the plane? (if so I’ve created lots of these types of plans previously and these has never happened before)

FYI the overall file looks like this:


#6

Contrary to your perception, SU is a full time 3D environment.

Sharing the model file would help us help you.
The image suggests there are hidden edges in the model.

Look to the top menus.
Click … View > Hidden Geometry

Setting the background to some color other than white would enable you to discern which is background and which is a white default material front face.

Look to the top menus.
Window > Styles
There, in the drop-down menu select Default Styles and choose Default Style from that list.


#7

Thanks. That’s really helpful - can I ask how all this extra geometry might have come about?

Group 6.skp (2.4 MB)


#8

You have not kept all your geometry exactly on the z=0 plane, which caused SketchUp to create hidden folds in some faces:


#9

By default, SU’s modeling tools draw geometry upon the Ground Plane when the camera view is predominantly looking down, such as when the camera is in Top View.

However, the model geometry is neither on the Ground Plane nor is it all in one plane.
The model is ever so slightly twisted with vertices ranging from 0.000086mm above to -0.012907mm below the Ground Plane.

My guess is one or more errant Move operations.
The hidden edges radiating from corners are SketchUp’s automatic attempt to preserve faces.

See this copy of the model:
Group 6_Review.skp (977.1 KB)


#10

your using length snapping and too low of a precision for the level of detail…

those can create distorted geometry…

you also have far to many materials, styles, components to model efficiently, not mentioning reversed faces…

john


#11

Thank you all. You’ve been incredibly helpful.


#12

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.