Weird grid in Layout after using "Render model on Page" option

Hi, I’m testing Sketchup 2024 with Layout because the update feels like a super improvement, but I’m facing a weird behaviour.

Any idea what could be causing this in Layout? There’s a grid that only appears when I choose: “Render models on Page”. If I select the viewports and render them using “Sketchup Model” tab, everything is fine.

It happens no matter if the experimental engine in Layout is on or off.

I wouldn’t feel comfortable uploading the files publicly but if someone would need to dig deeper in the model, I can send it via private message. But who knows, maybe that won’t be necessary.

I don’t know what it could be – happy to receive the file privately.

Arek – the Layout file you shared with me cannot open in 2023 for me.

It did open in 2024 but after trying to edit the viewports Layout stopped responding.

Maybe someone else might be able to help…

I might be able to try.

I’ve been going through your LO file but it’s very very slow and I’m having to wait for viewports to render. So far I have not seen the grid that you show in your screenshot.

I took a few minutes to look at your SketchUp file. A little bit of incrrect tag usage.
Screenshot - 4_11_2024 , 2_46_07 PM
Some stuff, including a whole lot of unused styles to purge.
Screenshot - 4_11_2024 , 2_49_32 PM
And a few excessively large textures. After making them more reasonable the file size was reduced by about 25%.

I’ll keep looking at the LO file as viewports render but I’m not sure I’ll see anything useful.

Yeah, I’m aware of the mess in my model. Sorry about that.

If you’re not getting the grid while using Render Models on Page then I’m beginning to think that this might have something to do with my drivers. Which version you’re using? Mine is the one reccomended for vray which is
551.86.

Other thing my be repairing the installation of SU2024 on my machine, although I ran the installation package as the administrator in the first place.

I wonder if it’s graphics drivers. I haven’t managed to get the grid to show no matter what I do.

I’m using SketchUp and LayOut 2024, too.

BTW, please complete your forum profile.

Does choosing Repair option reset my Plugins and workspace?

I wasn’t really asking about the version of Sketchup but the version of Graphics Cards drivers you have installed on your computer. I would like to install the same version you have and see if that helps.

No. It doesn’t touch those files.

31.0.15.3667

Ok, it’s gone. Not sure what helped.

What I did:

  1. Performed a clean install of Nvidia Studio drivers (same version) - I don’t think that helped because I have other project when the same thing still occurs.
  2. I resized 3 huge textures with Material Resizer. After that, I used CG Impact Report plugin to look for the heaviest models and then used Transmutr to make them lighter. That were only like 10 components I changed and then ran them through CleanUP plugin, Purged unused Materials and Components (without Purging Tags or Styles)

I did not use the Repair option.

Let’s see if point 2. works on the other file.

EDIT: I was too Not really gone. It’s gone in SOME viewports, in others not. I’ll keep digging. But I will send you guys the files once again if I may.

1 Like

Wow – so much detail !

Even with the cleaned up files it’s still slow.

And I remembered the new 2024 Layout draft mode !

Your file is better with draft mode enable but those internal door gaskets for example – do you really need those ?

All the detailed components in SketchUp – are they all tagged so that you can turn them off on Layout for the viewports that don’t need them?

A hunch – that Hatch-Net style – I vaguely remember a Brightman video about some clever hatch technique.

I can’t remember how it worked – it’s a watermark.

Somehow – is this the “grid” that you are seeing in Layout ??

I can’t see the grid pattern – I’m using 2024.

The navigation in the file is absolutely stunning for me in 2024. Both Sketchup and Layout. Not sure why you’re getting slowdowns as it’s completely smooth on my computer.

Anyway, I still can’t figure out where that might come from. If you take a closer look at the viewport with Door, this is where the problem occurs. This viewport is rendered as hybrid.

Did you try using Render Models on Page command to recreate the “grid” effect?

Animation

In 2024 I don’t have draft mode enabled and my viewports are set to render automatically because I don’t have performance issues.

When I opened up your Layout file, Layout ground to a halt.

With auto render off and draft mode enabled performance is way much better but still occasionally slow compared to what I’m used to.

Anyway – you have so many pages – I chose some random ones and did Render Models on Page and no grid appeared.

Hey! Don’t put this on me! :wink:
We do have some watermark hatches that utilize the blend slider toward image. Doesn’t appear to be one of those.
The only place I’ve seen a grid like this is when a group or object is hidden and “view hidden objects” is enabled in the style.
When I insert the model into a clean LayOut template, I don’t get the grid?
I would start with a massive purge, cleanup, and optimization of this entire project and then see if there are still issues. Both files are heavy!

1 Like

Downloaded fresh files from you.

This is what I get…

Layout_Strange_Grid

I ungrouped the stack of viewports and it seems that the viewport that has the doors and windows is doing something unexpected…

Yeah, I figured that out too. Looks like the grid is the floor group so I tried to explode it, reset tags, group again, assign tags again. Now, after copying to a completely new file, setting up the scenes from scratch I get the same result.

My guess is that this has something to do with the software - drivers or other stuff which I am completely unfamiliar with.

I reckon it would be great if someone from the Sketchup Team took a look at that to at least rule out the possibility that it’s Layout 2024 malfunction.

on that image it almost looks like there is an hidden object on the floor and that hidden objects are turned on in the style panel (the last one, blue cube)


That’s other viewport than presented earlier but the behaviour is the same. This is how the settings look like.

hmmm… looking again at the isolated view, any reason this viewport is in hybrid ? since all you need is the linework for the doors, and it’s already vector anyway ?

Can I have a look at the file ? (I have an hour to kill this morning)