Want to export only the edges

Hi there,

I’ve download SketchUp for my drawings project and I need to export only the edges of my 3D model. It means I don’t want to see walls and all of that. but the problem is that even if i’m using a style where you can only see the edges in black on a white background, when I export this in a jpeg format, white is not transparent. So how can I export these edge without any background ?


Jpg’s do not support transparency. You can export a PNG with a transparent background. You can also edit the exported image to make the white transparent.

But even with PNG there is still white, the only way is to edit to make the white transparent ?

You could make a Wireframe export but you’ll see all of the edges on the back of the 3D model. If there are faces in your model, they will be exported.

What are you going to do with this image after you export it from SketchUp?

Look under the Export Options button.

if you view on a white background a transparent png will seem to be white…

change your viewers bg colour to check for transparency, some use checkerboard…


Geo, I mentioned exporting with a transparent background but the faces in the model will still be exported as I said before.

So we can all understand what you’re doing, might you use the terminology you see in SketchUp.

From here, it sounds like you’re viewing the model in Wireframe wherein only edges are rendered, no faces.
And you want to export an image of the wireframe model which has a transparent background.
Is that correct?

Exporting a PNG with the Transparent Background option ticked will do just that.
Here’s a screenshot of such an exported PNG as viewed in an image editor.
The checkerboard indicating transparency.

A more normal view of the model in Monochrome Face Style.

Here is the problem ! The faces are in white in sketchUp so when I export this it’s in white too ! I want to get only the edges like in your image… where can I see this, “wireframe” ??

(sorry if I not explained well i’m french)

Wireframe is a setting under View>Face Styles.

Even if I check wireframe I still have this in sketchUp :


And after the exportation I only have the fond in transparent, not the faces.

Did you select the sketchy style after selecting Wireframe? Try Wireframe after selecting the sketchy style. when I do that and export as PNG, there are no faces in the export.

You never did tell us what you plan to do with this image once you have it. It would help to know. I frequently use hidden line exports over other images but I don’t ever find the need to make the export transparent. For example, this image has a hidden line export over a rendered image of the model. the hidden line export is just black lines on a white background.

HAH ! Thanks it finally works !

I’m using those edges for some plans of different rooms for my comic. You can see a tutorial just here -this is why I’m using sketchUp today- :

and I just want to try to draw something like that. So I need different types of edges to put on a colored and 3D background to see this like if it was a drawing.

It looks like you could do the same thing I did with the table image. White background and faces. Set the layer for the line export to Multiply and the white areas will be transparent.

Yes thank you ! Hah finally…