Walk Around Model and Zoom Issue


#1

My model is a huge city, 6.5km at the widest. I have an issue that when I zoom into it, to take screenshots and move around, anything close to the camera gets cut off.

My other issue is that I want to find some piece of software that let’s me walk around my city or house or any model. I want it to be freeware, as I am not doing anything professional with it and can’t afford a 200 CAD price tag for something.


#2

Is the model scaled properly? If it has 6.5km in reality but 10m in Sketchup, you’re gonna get something that’s called “near plane clipping”. That happens because Sketchup cuts off everything that gets too close to the camera (eg. less than 10cm). If you scale the city up, this shouldn’t be a problem anymore.


#3

Talking about your second issuee: it should be possible in SketchUp! Well, kind of.

SketchUp’s got tools called Position Camera, Walk and Look Around. They’re hidden in the Camera toolbar, you can show it by going to View>Toolbars and checking the “Camera”.

Select the first tool (Position Camera), click on the ground and type the height of your “person” to the Value Control Box. Then select the third tool (Walk) - by dragging with left mouse button, you walk. When you press the mouse wheel now, you can look around.


#4

Yes the Model is scaled properly, I made sure of that.


#5

I’m not a fan of that feature because of the other issue. When walking around, any close details are gone. The walking is also wonky, and I would rather use WASD and the mouse to look around, like all games on PC do.


#6

Interesting… Could you share the model or is it private or something?
Try to check these issues:

  1. If it’s an imported model (from a different app), try to Explode everything
  2. Check if the origin is close to the model (preferably in the middle of it)
  3. Check if your Field of View is ok by either Shift+scrolling or going to Camera>Field of View and setting it to approximately 30°
  4. If there are any components, check whether their axes aren’t too far away.
  5. Experiment with scaling the model to different sizes.

A related help topic:
http://help.sketchup.com/en/article/36261

.

I couldn’t find any extension for “walking through” a 3D model. If nobody else knows, you’ll probably need to google :wink:

EDIT: This looks promising: http://workshops.ko-opmode.com/


#7

Well, maybe my model is just TOO big. It’s a huge one, a full sized 6 x 6 km city. I wish I could take some decent screenshots though, that’d be nice. It only works when the FoV is set to 1.