Vray Undefined Method 'klass' error

Hi. I have been trying to render my model but an error keeps popping up saying “undefined method ‘klass’ for nil:NilClass”

kindly help

You’ll get a faster response if you post in the Vray SketchUp Bugs forum at Chaos Group’s website …

https://forums.chaosgroup.com/forum/v-ray-for-sketchup-forums/v-ray-for-sketchup-bugs


Also be sure you are running the correct Vray version for your SketchUp version.

hi…thank you for your response.
im currently using the sketchup pro 2018 with vray next 4.0 and windows 10
the problem however persists with just one particular model…im able to render my other projects.

Again, go to the Chaos group forum for SketchUp bugs and follow instructions how to post.

You can try posting the model or link to the model and I can see if it gives me the same error message.


If it does, pelase submit the log reports to : support@chaosgroup.com

I wil log the typo there!

Hello,
I have the same problem. Did you find the solution?
It’ urgent, I have to finish a project this week-end!

Thanks a lot for your quick anwer!

I just found the solution, it was faulty section planes.
I delete it and now it works.
I still don’t know what was faulty in these section planes.

1 Like

Hi, just want to add on anyone who’s having this kind of problem in the future. I’m having the same problem & in my case is the material with image (perforated image) in my case. hope it helps.


please help!

please tell me what’s wrong

He said it was a faulty section plane, maybe you have it , too in your model.

I didn’t find what was wrong in my section plane but I suggest you to delete all your section plane and try it again.
For me, it was one section plane inside one component.
Hope this can help

É um erro bem simples, está ocorrendo um conflito entre os cortes do projeto, basta excluir todos eles que voltará ao normal, todas as seções que foram criadas.

1 Like

I DID IT!
For me was that I start deleting each component of the scene that a had added and hit the render button each time to try it, it turns out it was some TV I had download from the 3D Warehouse. Once the TV was gone everything went back to normal and i was able to render. I know that sounds exausting but that was the only thing that worked.

Amigo, me ajuda! Como apagar esses cortes ativos? Pelo asset? Já revirei tudo e não consigo. Dois arquivos que têm dado esse mesmo problema!