Vray Render Taking 6 Hours PLEASE HELP

My vray renders are taking 5-6 hours. I don’t have this type of time as I need to hand in tomorrow at 12am. Any help is appreciated.
Thank you!

Using Macbook Pro M1

Without yet taking a look at your model, you are using the Denoiser, so probably you can turn down the quality to Medium without any visible difference in the output.

Also be aware that because Vray doesn’t support GPU accelerated rendering on Mac, it will unavoidably be slower than on a Windows pc with an Nvidia graphics cord that supports CUDA hardware. If you can find someone who would let you use such a PC things would go faster.

This one took about 15 minutes on my PC. I switched the quality to Medium and turned off the rectangle lights that were so weak that they wouldn’t have impacted the rsult much anyway. Reduced the size for the forum. I have a Nvidia graphics card so I used the RTX mode to render.

There is a lot needed to help you with here but since you seem to be on a tight deadline, I’ll try to keep in simple.

First, make sure you don’t have reversed faces in your model. They can cause problems.

This is what the render looked like on my end. It took me 15 mins after changing quality to Medium - which felt like a long time for my iMac Pro. Did you mean to have your contours (edges) showing? Regardless, my suggestions are, like @Anssi , try to use daylight when you can rather than relying on rectangle lights. Rectangle lights can be used to supplement environmental lighting as needed.

I also noticed you’re using ‘Glass Crystal’ for your windows. That has a lot of extra refraction settings which likely is slowing things down. Just use the default Glass material from V-Ray…or Glass-Window Neutral.

Here is another render after I turned your rectangle lights off and relied more on the sunlight coming in through the windows and your hanging lamp. I also reset V-Rays settings back to the default. It rendered in 3 mins vs 15. There was something wrong with the windows where they weren’t rendering correctly for me so I just turned them off for this example.

The missing plant and some other entourage elements were from the Cosmos collection. They showed up in renders after downloading them.
This is what your first scene looks like without any tweaking except setting quality to medium

The problem with these is that the light is not coming from a visible source but from some sort of nuclear glow. A pure daylight view would in fact be much darker, with surfaces facing away from the windows almost black.

Thank you very much for your help. I had put those rectangle lights in as the render kept on showing up very dark when relying on the natural sunlight. I have turned them off and moved down to medium, and taken off denoiser and still looks like this after 20 minutes.
I am a student and followed the lecturers setting instructions provided.

I’m not sure why it’s taking so long on an M1 chip. I have few other suggestions but perhaps sending it to the Cloud for now could be the best option. You should have received some render ‘credits’ with your V-Ray license. Check out this video showing how to send your file to Chaos Cloud: How to Render ONLINE | Chaos Cloud for Sketchup - YouTube

Even the EDU license should come with 10 credits:

Also be sure to swap out that window material as the Glass-Crystal adds to your render time.

In case these would be of any help, here are the scenes in your SketchUp file rendered using your original lights and settings except for Quality that I turned to Medium.
views.zip (13.3 MB)


Thanks Eric,
Would you mind letting me know how you got the pendant light to show? It is turned on in my settings but does not show on my interactive render.

I used a sphere light, not the spot. Inside your pendant, the bulb most likely would be a standard bulb - so sphere works the best. Consider making the pendant material transparent as well - assuming the intent is that the light comes through, like a paper lantern.

1 Like

Ive managed to get a render one in Medium + but the material on the green chairs are all fuzzy. Gone over with denoiser and tried altering the sharpening/blue effects too.

Not sure the problem but something was changed in your velvet material. You can see in the material preview that it’s showing as black, rather than green.

When in doubt, remove the material, re-import from Cosmos, and re-apply. here is the original on the left next to a new clean version on the right. *this may help speed up your render times as well!