Viewing Sketchup models in Google Earth street view

I’ve got a model (an archway over a road) that I’m trying to view in Google Earth Pro street view but it’s not showing up. I can see it fine in ground level but as soon as I switch to street view it disappears.

Is what I’m trying to do possible? And if so, how?


Street View is a set of photosphere photographs, they were taken long ago, and don’t include any models.

So no way to insert in one I’ve made?

I don’t think so, even the official Google Earth models are hidden when you go into street view.

I remember doing something similar in the past…

I put ‘something’ in front of my friends house and sent him a link while he was away…

but it was to a page on my wed site, not the real streetview…

a bit like this example by this guy

I not sure that google still offer even this ability, but it may be worth pursuing…


I am running GE 7.1.5 and when you dive down and automatically switch to streetview mode, there is an option to remove the streetview imagery and view you KMZ model.

The button is at the upper right of the screen

1 Like

That is useful to know, but isn’t quite the same as what kat1 is asking for.

Oops… I misread the post. Sorry

We’ll just mark that up as an FYI :wink:

Hmm this would be close to what I want, albeit likely beyond my skills. I’ll look into it though, thanks!

I know this post was from almost 2 years ago, but has anything changed since? I’m trying to do something similar and having the same issues. Wondering if someone or some company has developed a plug in to help us with this. Let me know, thanks.

I doubt it. Since the street view is just photos taken of the surrounding area as the GE car drives down the street, there’s no way to insert the SketchUp model into the photos.

There’s no direct option to us street view images as textures like there once was but you could use your own images of the surroundings as textures in SketchUp.

You could try my solution - I did a SU model of my house, saved as a KMZ, opened it in Google Earth Pro with 3D turned off and kept tilting down and around until it was nicely visible. NOTE: When 3D buildings"Realistic" was turned on the Google Earth “impression” of the house showed and did spoil parts of the model. This may or may not work for you or affect your arch but may be worth a try?

As Google hasn’t owned SketchUp for about 5 years, you would do better posing this question on one of their own forums!

1 Like


i am using sketchup pro 2022 and had the same issue when importing the kmz file. it was a very simple mass model and still would not display on streetview. Once i clicked and switched to “ground level view” (the 3D box icon), the model study showed up. Thank you!!!