View.write_image png file quality is not great

I’m trying to get the highest quality of image using View.write_file.
antialias true
compression 0.0
transparent true
File type png
Size is 320 X 240

I’ve tried setting the view port to exactly 320 X 240
I’ve tried having a full screen for view port and quality doesn’t really change

The renderiing that sketchup does is very good - but the image isn’t

I can do a capture with faststone and the image comes out really good but that is painfully slow to do - to many steps

I have also tried fastone photo resizer and that works pretty well providing I have a reasonable image to begin with.

Anyone with experience with this?

This is from faststone - 36 K

And this is from sketchup - 30 K

In preferences there is a setting to set whether you want the original image image detail or not.

Check in Preferences, Preferences, see if OpenGl is set to allow Maximum texture size…

So I decided to go back to Sketchup 2017



When I first replied I didn’t notice you were doing this from Ruby.

2017 didn’t have the line scale multiplier feature. That defaults to being set to 2. If you set it to 1 the results should be the same as 2017.

Here’s a super close up of a line exported in 2017, then 2023 with line scale multiplier of 1, then 2023 with line scale multiple of 2. The first two look the same.

What is this “line scale multiplier” feature and when was it introduced ?
Why would it have been set to default to 2 when historically it was 1 ?

It came in with 2019.2. Don’t know why it defaults to 2.