Validity Check Adding Hidden Lines

Dear Community,
All week I have been trying to export a Revit house model into SketchUp but it’s just not working!

I have been able to do this before but not with out over 24 hours of needles work. I exported the model as a DWG and then into SketchUp. Then, by hand, I went though the model erasing coplanar edges and repainting all the faces. It was thoroughly exhausting and I never want to do it again.

Now I am using the rvt2skp plugin from SPK Technology. So far it’s gone really well. (until now that is!)
image

When I turn on hidden geometry I find all these hidden (Not Smoothed Or Softened!) lines cutting up faces into smaller triangles. See this roof piece:

So I erase them using the eraser tool witch works fine because they are coplanar lines. RIGHT?
Until the SketchUp validity check comes along 10 minutes later and destroys all my work by replacing in those hidden lines!
image

Here is a some of the walls that are giving me trouble.
Walls.skp (663.9 KB)
I can not include the entire model because is it contains confidential information but I can answer any questions you may have about it.

Please help me before I go crazy! :pleading_face: :crazy_face:
Thank you!

Have you tried contacting SPK Technology about this?
Have you tried using something like ThomThom’s CleanUp plugin instead of the eraser tool?
The errors point to the faces not being truly coplanar but off by a very tiny amount, not affecting the Eraser tool but detected by the internal validation process. This would be an issue with the export plugin.

I have not contacting SPK Technology but I am using ThomThom’s CleanUp plugin and others ones I have built.

I understand why it’s not working. I just want to know how to stop it.

I really hope not but I think your right!
Do you think I could fix it with a homemade extension?

What happens when you export as IFC and then import it with the IFC-manager extension in SketchUp?

Excuse me @MikeWayzovski, what is a IFC? I haven’t heard of that name before.

Thank you very Much! I will try it. :slightly_smiling_face:

Does anyone else have any solutions for this problem. :pleading_face:
SketchUp is still misbehaving! :confounded:

Sketchup is probably doing what it is told.
Unless we can see the original we are unlikely to be able to guess the issue.
@Anssi has already given you the most likely reason. Asking us how to stop it requires us to know what it is.
Perhaps if you hold a banana in your left hand while importing it.

Thank you @Box. You are totally right. I added a piece of the model to the topic description above.
At this point I might take you up on that banana idea! :banana: :laughing:

1 Like

Try opening a new model, go to Window/Model info/Unit and untick ‘Enable Length Snapping’ and try the import again.

There are two reasons why I can’t do that.

  1. The extension is installed on Revit witch then exports a SketchUp file.
  2. I don’t have Revit on my computer.

I’m a bit lost as to your reply. Length snapping is part of sketchup not revit.
However it is well past my sleep time.

1 Like

PROBLEM FIXED! :joy: :clap: :joy: :clap:

I have just figured out how to fix this problem. Don’t ask me why this works or how I figured it out because I don’t know!

To prevent SketchUp from raising errors about the CFace equation do the following for each component or group:

  1. Explode the component or group
  2. Erase the coplanar edges
  3. Regroup the entities

And that’s it!